Report ID - 1926548813

When Zotero syncs I receive an error like the one pasted below. I tried removing a record I thought was to blame, but that did not fix it. I do not see this error on my other machines synced to my account. How do I resolve this problem?

[JavaScript Error: "TypeError: messageManager is undefined" {file: "resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///home/casey/.mozilla/firefox/mwad0hks.default/extensions/jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack.xpi!/bootstrap.js -> resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/commonjs/sdk/context-menu.js" line: 690}]
  • could you try disabling all other Firefox add-ons and try again?
  • edited April 4, 2015
    Disabling other extensions is unlikely to help with this. Here's the relevant errors:
    [JavaScript Error: "Not deleting symlink '[...].pdf' in Zotero.Sync.Storage._deleteExistingAttachmentFiles()" {file: "chrome://zotero/content/xpcom/storage.js" line: 1784}]

    [JavaScript Error: "[Exception... "Component returned failure code: 0x80520008 (NS_ERROR_FILE_ALREADY_EXISTS) [nsIFile.create]" nsresult: "0x80520008 (NS_ERROR_FILE_ALREADY_EXISTS)" location: "JS frame :: chrome://zotero/content/xpcom/file.js :: Zotero.File</this.createShortened :: line 326" data: no]" {file: "chrome://zotero/content/xpcom/file.js" line: 660}]
    This should be fixed in the latest 4.0 Beta. I'm guessing you have your Zotero data directory or its 'storage' directory symlinked.

    You can install the beta over your current version and try syncing again. You can revert to after the sync goes through, though you may have trouble with other files. If you do revert to, you'll want to delete the pdfinfo/pdftotext files in your Zotero data directory and reinstalling them from the Search pane of the preferences after downgrading, since the versions installed by the beta won't work properly with

    Otherwise, you can just wait until 4.0.27 comes out and switch back to that then.
  • edited April 9, 2015
    Thanks for your replies. I don't have the storage directory symlinked on any of my installations. It sounds like waiting for 4.0.27 might be the best solution. FWIW, I have Zotero on three machines, an it is only one of my Linux installs that has this behavior.
  • Try, which includes the relevant fix. (I'm not sure how you would get the above error without there being a symlink somewhere, though. Maybe you somehow ended up with a symlink for the PDF in question?)
  • I just upgraded to on the affected installation, and the error disappeared, so thank you. FWIW, I tried before deleting the record with the PDF in question from my collection, but that didn't fix the error.

    I would also like to thank you and the other developers for producing just a fantastic research tool. I am an assistant professor of biology, and I introduce Zotero to all of my students. It is such an effective tool for sharing scientific literature, especially with my research students. They frequently tell me how much they wished they learned of Zotero before!
Sign In or Register to comment.