PDF retrieval error


I'm getting the "unexpected error" message when importing metadata for a PDF. I looked through the forums and tried to install the beta, but no luck.

http://jeffhuang.com/Final_StarcraftSpectator_CHI11.pdf as the test PDF.

Error report number: 1799324977
  • This time with debug output: D1837791286
  • works for me -- @Dan, anything in the debug?
  • (4)(+0000001): Translate: Binding sandbox to http://scholar.google.com/scholar?q="the spectators are and why they spectate; ii)%20we%22%20%22information%20to%20the%20spectator%20as%20possible%2C%20it%20is%22%20%22games%20are%20primarily%20designed%20for%20the%20players.%22%20%22made%20or%20distributed%20for%20profit%20or%20commercial%20advantage%20and%22%20&hl=en&lr=&btnG=Search

    (4)(+0000007): Translate: Parsing code for BibTeX

    (3)(+0000019): Translate: Beginning translation with BibTeX

    (3)(+0000013): Translate: discarded item from BibTeX; type was mediascreenand

    (3)(+0000004): Translate: discarded item from BibTeX; type was mediaonlyscreenand

    (3)(+0000005): Translate: discarded item from BibTeX; type was mediaonlyscreenand
    Cookie settings, maybe.
  • The privacy settings were at default, and I'm accepting cookies and remembering history. (True in real life as well.)

    No change, still get the error. Not for all PDFs, it seems: just successfully retrieved metadata for another one.
  • for the one where it's working, what does it say under "Library Catalog"?
    I'm assuming it says CrossRef, which is the first thing Zotero tries. Google scholar seems to be failing.

    How about importing directly from google scholar via URL bar icon, e.g. http://scholar.google.com/scholar?hl=en&q=labor+market does that work?
  • Yep. The one that worked retrieved from CrossRef. Unable to import from Google Scholar.
  • Let's try this:
    go to google scholar, click on the arrow on the webpage at the top right-->settings and at the bottom under "Bibliography Manager" select "Show links to Import into BibTex"
    Click on Save, return to the google scholar page and see if you can now import via URL bar icon.
    If not, see what happens when you click on the BibTex link that should now show.

    If you can, try retrieve metadata for an item that previously failed now.
  • And I assume Dan would have mentioned something otherwise, but you are on Firefox 36, correct?
  • Yes, on Firefox 36.0.4. Now I can import from Google Scholar, but not for that document.
  • @Dan (or whuber if you feel like looking through the debug):
    about two lines above the debug output that Dan posted above there should be a line that looks something like:

    HTTP GET http://scholar.google.com/scholar.bib?q=info:UU8UCRi9c9QJ:scholar.google.com/&hl=en&as_sdt=0,24&ct=citation&cd=1&output=citation

    Is that in the Debug?
    @whuber -- if you follow that link, what exactly do you see?
  • I get this message:

    Your client does not have permission to get URL /scholar.bib?q=info:UU8UCRi9c9QJ:scholar.google.com/&hl=en&as_sdt=0,24&ct=citation&cd=1&output=citation from this server. (Client IP address:

    Please see Google's Terms of Service posted at http://www.google.com/terms_of_service.html

    That’s all we know.
  • edited March 27, 2015
    That's actually expected. You would have to first go to https://scholar.google.com/scholar?q=labor+market&hl=en&as_sdt=0,14 make sure the "Import into BibTeX" link is visible (if it's not, then go to settings and select that option as per above") and then go to http://scholar.google.com/scholar.bib?q=info:UU8UCRi9c9QJ:scholar.google.com/&hl=en&as_sdt=0,24&ct=citation&cd=1&output=citation

    I'm guessing that these steps will work and it's really changing the setting to display the BibTeX link that Zotero is unable to do. The only way we've seen this happen is if your cookie privacy settings are too restrictive as outlined on the troubleshooting page in 10.I. I suppose it would also be possible if you have some third-party extension that imposes additional cookie restrictions. whuber (or Dan) do you have any extensions installed that may be interfering? Can you disable other extensions and try importing from a Google Scholar page again?
  • I'm afraid it's not working. In fact, it looks like cookies are sometimes being deleted from my Firefox. I'm not sure why. I'm using a fairly bog-standard antivirus, default privacy and security settings, etc.

    I've set Scholar to display BiBTeX information, and still not able to visit http://scholar.google.com/scholar.bib?q=info:UU8UCRi9c9QJ:scholar.google.com/&hl=en&as_sdt=0,24&ct=citation&cd=1&output=citation or import PDF metadata.
  • Did you disable all other extensions?
  • I disabled any unusual ones, but left the usual standard ones (AdBlock, Evernote Clipper) intact.

    I've just disabled them all, and it worked. Then I re-enabled them one by one, and it still works. Not really sure what it happened, but for the time being, I'm able to import PDF metadata, and finally the cookie for my Google Scholar settings seems to be persisting between restarts. Thanks for your help, I'll reopen this if it comes back (although it is starting to look like a Firefox/XUL issue, rather than a Zotero issue.)
Sign In or Register to comment.