No attempt to download PDF from APS journal website

The American Physics Society (APS) has updated the look of their webpages, and it may have broken the Zotero translator. When I click on the article icon in the URL bar of an APS journal article, Zotero correctly downloads the citation information but now makes no attempt to download the PDF. In the little box that appears in the lower-right hand corner after clicking the icon, it only says

Saving to [folder name]
[Article icon] [Article title]
[Webpage icon] APS snapshot

In particular, no PDF icon appears with a red 'X'. I am able to manually download the PDF immediately without problems, i.e., there's no CAPTCHA prompt or anything.

Note that this is a different problem than the one recently reported here:
  • Sample URL? Also, if possible, submit an error report
  • Sorry, you're right. Here's a sample URL:

    I checked a couple other articles from different journals like Physical Review A, and they had the same issue.

    I submitted an error report (error report #: 2022162657).

    Incidentally, this post (which I hadn't noticed before) just became active 30 minutes ago.

    Likely related.
  • what setup is this on? Standalone? If so, which browser?
  • edited March 18, 2015
    Also made sure that Zotero was up to date (, and I updated the translators via "Update Now" button in the general tab of the Zotero preferences. I only use Zotero Standalone, on a Mac, with Chrome. I restarted Zotero. Still having the problem.
  • Reset your translators from the Advanced → Files and Folders pane of the Zotero preferences. At least one of your translators is corrupted. If that doesn't help, try temporarily disabling ZotFile, since there's at least one error from that in your report.
  • And, finally, make sure you've restarted Standalone. If you're still having trouble after all that, provide another Report ID.
  • Translators reset. Restart Standalone. Disable ZotFile. Restart Standalone.

    I tried getting the translator to work after each step, without success.

    I restarted Standalone and immediately submitted an error report (Report ID: 501472685). Then I tried running the translator on an APS article and submitted a second report (Report ID: 1557165264).

    The only errors that seem to persist are

    [JavaScript Error: "bad script XDR magic number"]
    [JavaScript Error: "bad script XDR magic number"]
  • OK, no errors in there, so can you provide a Debug ID from Chrome for the save attempt?
  • Sure, done. The Debug ID is D1579771956.
  • OK, that all looks OK. How about a Debug ID from Standalone for the same?
  • Done. The Debug ID is D378566808.
  • And you're sure that Zotero is set to download PDFs in the General pane of the preferences? This works for me from that page, but I don't see an attempt to download a PDF in your debug output, so if that setting is enabled, someone will need to take a look at the translator to figure out what's happening.
  • edited March 18, 2015
    Yep. I confirmed that the "Automatically attach associated PDFs and other files when saving items" was checked. I also tried clicking the icon to save a citation from a non-APS journal, and Zotero correctly downloaded the PDF.

    Like I said at the beginning, it really looks like the Zotero Chrome connector isn't even trying to pull up the PDF, because there isn't ever a PDF icon in the box in the lower right hand corder that appears after you click the icon in the URL bar.

    My best guess is that this is an issue with the APS translator choking on the new design of the APS website. Maybe they are rolling it out selectively? This is what I see, which looks slightly different than it used to, especially near the buttons and tabs ("Article", "PDF", etc.):
  • Here is what the APS website looked like up until a few days ago:
  • The translator has been updated to work with the new design and is working correctly for Dan, me, and (I assume) adamsmith. Can you right-click the page, select "View page source", select and copy everything on that page, and post it to ?
  • Yep:
  • When on the APS page, type "javascript:" in the address bar and then paste the following right after and press Enter
    alert('Testing...');if(document.evaluate('//div[@class="article-nav-actions"]/a[contains(text(), "PDF")]', document, null, XPathResult.ANY_TYPE, null).iterateNext()){alert('OK')}else if(document.evaluate('//div[@class="article-nav-actions"]', document, null, XPathResult.ANY_TYPE, null).iterateNext()){alert('no link');}else if(document.getElementsByClassName('article-nav-actions').length){alert('div is there, but not picked up')}else{alert('failed')}

    You should see two alert popups (unless you have some extension that blocks this). First will say "Testing...". What does the second popup say?
  • The page at says:
  • Can you disable all of your other extensions in Chrome and try again?
  • Sorry, I mean try importing the item again, not the javascript I posted above.
  • And while you're at it, can you import the article from ?
  • OK, so I disabled all chrome extension besides Zotero connector, opened a new tab, went to the article webpage, and tried importing again. No change.

    Then I went to URL you sent me ("Accelerating Cosmological Expansion from Shear and Bulk Viscosity"). Interestingly, when I tried to import this it doesn't work at all. If I click on the icon in the URL bar then the box pops up as expected in the lower right hand corner. However, inside the box it only says

    Saving to [folder name]

    and in particular does *not* say [Article icon] "Accelerating Cosmological Expansion..." underneath, as I expected. And nothing appears in the Zotero standalone client.
  • OK, I think your translator is still not up to date.

    Close Chrome, open Zotero Standalone, go to Preferences -> Advanced -> Files and Folders -> Reset Translators... Wait 10 seconds. Close Zotero Standalone.

    Open Zotero Standalone. Go to Preferences -> General -> Update Now. Wait for it to say "Updated" (btw, do you have the checkbox ticked to update your translators automatically?).

    Now go to Preferences -> Advanced -> General and Enable debug logging. Open Chrome, go to and attempt to import that article. After it fails (if it still fails), go back to Zotero Standalone, Preferences -> Advanced -> General and submit the debug log. Post the debug ID here.
  • OK, that fixed it. I was able to correctly import both the article you sent me and the original one that started the problem. Thank you very much.

    Is there something I could have done differently? Obvious in the future I'll try restarting Chrome if I have issues with the translator, which I feel a little sheepish about, but I presume the translators are supposed to update without that.

    (After I clicked the "Update Now" button it said “Up to date”. And I have always had the checkbox ticked to "Automatically check for updated translators and styles".)
  • edited March 18, 2015
    If you hadn't restarted Chrome since this whole issue began, then I guess that could explain this (since your translators had been corrupted in Zotero Stadalone at first). You generally don't need to restart Chrome to get updated translators though.
  • Nope, I hadn't. I usually have chrome run for days without restarting.

    Thanks again.
  • I have a similar problem. PDF files from APS journals are not added to the citation (but everything works fine for the NPG journals). I followed the steps described above but this did not resolve the problem.
  • It seems that APS has included a "Verification Request" page after clicking on the pdf:
    Please click on the image of Albert Einstein below.

    We regret having to add this extra step for our subscribers, but have found it necessary due to systematic automated downloading of our content (in violation of our Terms and Conditions).

    [8 images are following]
  • Well, that's a shame, given that the CAPTCHA does almost nothing to actually protect their content (and also completely breaks accessibility in its current state), but we should probably give translators the ability to return error messages in place of attachments and show a message in the progress window telling people to solve the CAPTCHA once and then try saving again.
Sign In or Register to comment.