php based WebDAV server - can be used with any (e.g. free) hosting plans and via standard ports

  • The filenames are base64-encoded, with "%ZB64" at the end. The limitation is lifted by for Firefox 10.
  • thanks, Dan. I cannot believe I never noticed this before (or more likely: totally forgot that I ever noticed). But then again, it's probably been a while since I opened a zip file on my Zotero WebDAV sync server.

    @gadietrich: I have adjusted my workaround description above to take this into account.
  • Dan: Thanks for the clarifications on the encoding and zipping, and what is and isn't changing post Fx10. I certainly see why adding WebDAV attachment support to may not be worth the substantial effort required. I will be exploring it for Zandy at some point, but I know that it's not a trivial proposition.
  • @Dan. Just for clarification: will zotero cease to encode the filenames in the zip file once Firefox's limitations will not require it to do that anymore or will you just leave this as is since this sort of under-the-hood stuff doesn't really make a difference to users either way? I am asking since that would change the way my program would have to deal with these files (check for encoded file names rather than just decoding them without check).
  • You should check for the suffix. We'll stop encoding when we can (though that won't be for some time, obviously).
  • @gadietrich and others

    I have just released version 2.0 of my phpZoteroWebDAV script which now includes a library and attachment view of all synced library items.
  • First, thanks to krueschan!

    After installing, I can not see any attachment detail info. I tried output the requested string of $zotero->getItemChildren. I can not find any "<entry>". Maybe result string of zotero request changed. So, details.php need some modifications. I changed all "<entry>" into "<entry". It seems ok.
  • I believe I've successfully installed and configured phpZoteroWebDav under my domain. Zotero has verified its ability to connect to the service. It has started to sync (two zip archives have been uploaded to the /zotero/ storage directory on the server).

    Yet, the sync didn't complete but instead gives me the following error:
    [JavaScript Error: "1449576167134 Toolkit.Telemetry ERROR TelemetryStorage::loadAbortedSessionPing - error removing ping: PingReadError JS Stack trace: PingReadError@TelemetryStorage.jsm:80:15 < TelemetryStorageImpl.loadPingFile<@TelemetryStorage.jsm:1440:13" {file: "resource://gre/modules/Log.jsm" line: 749}]
    [JavaScript Error: "HTTP 404 from WebDAV server for HTTP PUT" {file: "chrome://zotero/content/xpcom/storage/webdav.js" line: 151}]

    version =>, platform => Win32, oscpu => Windows NT 10.0; WOW64, locale => en-US, appName => Zotero, appVersion =>, extensions => Zotero LibreOffice Integration (3.5.10.SA., extension), Zotero Word for Windows Integration (3.5.2.SA., extension), Microsoft Office 2016 (16.0.6001.1038, plugin), Google Update (, plugin)
    I've closed and reopened Zotero and tried to sync again, but the same error still appears. Would anyone have any thoughts?
Sign In or Register to comment.