The attached file could not be found.

Somehow the PDF file "attachments" can not be found. Indeed they are no longer either in my live Zotero/Storage folder nor are they on my webdav server. But they were there. Note that all of these features have worked for me previously. I am able to find the PDF files in backups of the Zotero file (within storage and then in subfolders named like KHCH8IKX etc) on both of my computers.

I think this is my biggest problem now, losing my attachments (PDFs etc).
I have just copied all folders from within a good backup of Zotero/Storage/ folder into the current live Zotero/storage/ folder. The attachment files can be found again from inside Zotero. Now if the Sync does not throw an error I should be good (so far so good).
  • I have this problem to the point of making Zotero almost useless. It is very hard to find copies of files, or old web-pages, and to lose them is tragic. My error log was reported as 435715199. This is a great tool, and I wait patiently for it to work :-). I am using webdav to store attached files.
  • It seems as if I have the same problem:

    I also tried to open pdfs and snapshots, but zotero cannot locate the files anymore. I looked in the storage, but it seems as if the files have been deleted.
  • pjgoodall: We'll need more info. Read ebollrich's thread and let us know if you're experiencing the same problem. Are folders actually missing from the 'storage' directory within your Zotero data directory? If so, are older snapshots missing, while new ones exist? Some other pattern?
  • Dan, Please suggest a test case for me to run, and what to look for in the file-system. It looks very much like the same problem as described by ebollrich. At the moment some recent stuff is missing, and some older stuff is still there. Adding pdfs at the moment is not behaving correctly, probably as described by you in another post.
  • At the moment some recent stuff is missing, and some older stuff is still there.
    It's not the same problem as ebollrich's, then.
    Adding pdfs at the moment is not behaving correctly
    You'll need to elaborate on this.
  • Ok, I don't know how to debug your application, and have no visibility of its internals or architecture. So if you want me to help debug, then I need guidance. I have already posted a description of how adding pdf's is functioning for me. All I know is that it appears that some olde docs are still attached, whereas ones from within the last few days are not. I am syncing across 2 systems, a Mac and Win XP. Are there logs on these systems I can look at?
  • I'm not asking you to dig into the code hereā€”just to offer some specifics as others have done.

    I assume the PDF problem you're referring to is this problem of yours from another thread, in which case a simple link to that thread would have sufficed. At any rate, I've responded there. It's probably not related to this issue.

    The Zotero data page linked above explains the structure of the Zotero data directory, and files contained within the 'storage' subfolders are your own attachments. If you could take a few minutes to check, for example, if all recent files are missing, or only some, or whether you notice that any old files are also missing, or whether you only see files you created on the computer you're on now but not ones that should have been synced via WebDAV, etc., that would help. You might also compare the folders on your WebDAV server to ones in each local 'storage' directory. An answer to my question above as to whether the folders are actually missing from the 'storage' folder or whether they're just unlinked in the database would also be helpful.
  • I am also having problems with stored files on webDAV, zotero will upload, but not download onto other computer so keeps coming up with "attachment not found".

    I've described it in the thread
This discussion has been closed.