Zotero bugs when dragging notes containing more than 20.000 characters AND some formattings

I have tried to drag notes (stand alone as well as sub items) to move them under another citation (to change/assign the/a parent item) or on the tags in the tag pane to assign new tags but :

→ when a note contains more than 20.000 characters (I always used the HTML code to count the characters including the space)
→ when its text is formatted with headings + highlights + colored texts + bold/italic/underline text,
then zotero freeze and firefox doesn't respond anymore

I have tried with notes formatted with headings + highlights + colored texts BUT with less than 20.000 characters : it's always working

I have tried with notes of more than 180.000 characters but without any formatting : it's always working.

This is happening in Zotero firefox add-on and in Zotero stand alone

version of firefox 35.0.1
version of zotero (firefox add-on) 4.0.26
version of zotero SA 4.0.23
Windows 7

Any idea why this is happening and how to solve that?

My workaround (if some of you have the same problem):
● for assigning tags: I use a dummy note to assign the tags and then I copy the tags (with zutilo) and paste them on the note I am really working on
● for changing parent citation: create a new note under the "correct" parent item and copy past the content of the notes I want to move into this new note.
  • Report ID?

    Have you tried letting it go for a while when this happens?

    Does this happen with other extensions disabled?
  • edited February 16, 2015
    Thanks for your time Dan!

    Here the report ID (the tuto asks not to restart zotero before clicking on report a bug, but I had to, because my zotero is frozen once the bug start)

    Report ID= 914632996 (zotero firefox)
    Report ID= 846163564 (zotero stand alone)

    + For zotero firefox:
    Yes I have tried several time to let it go for more than 5 minutes but Zotero remains frozen and firefox is set as "not responding" in windows task manager. The only solution (so far) is to end the task and restart firefox.
    I have also disable all the firefox add-ons and the bug is still there.

    + For zotero stand alone:
    I have also tried to wait (2 minutes) but it remains frozen and set as "not responding". Here also the only solution is to end the start and then resart ZST.

    The same bugs happens under the same conditions with the same result in zotero firefox and ZTA so it seems related to zotero.

    Hope this will help you. Also I forget to mention that I am on Windows 7
  • I'm not able to reproduce this (at least on OS X, though I haven't yet tried on Windows).

    Could you try running Zotero with real-time debug output enabled and the console expanded as much as possible and visible (i.e., not hidden behind another window) to see if there's debug output while it frozen? If it stops during the freeze (or either way, I guess), take a screenshot of the last section of debug output, upload it somewhere (e.g., Dropbox), and provide a link here.

    Try this in Firefox first, which uses a slightly better logging method.
  • edited February 17, 2015
    I have run both Zotero firefox and zotero SA with the real-timedebug output but as expected the console freezes when zotero freezes.
    I have checked on both console, not a single line is added when I select the notes and drag it on a tag or on under a new citation.

    The bug only comes when there is a lot (like -really- a lot) of formattings so just to make sure it's not related to my computer/OS/..., I have copy-paste one of the note that creates the bug on this page so you could tried : (edit cf message below)

    I hope you will be able to reproduce the bug with this one!
  • FWIW, I'm not able to reproduce this either on Windows 7 (Zotero Standalone or in Firefox). Just in case, can you copy paste the whole content of the note to https://gist.github.com and post it as gist, then link to it here. It's possible that Joomla is stripping off something that causes these problems, though AFAIK Zotero doesn't even look at the contents when re-assigning the note to another parent item (are the items in the same library?)
  • Got it, thanks. Fixed in the 4.0 Beta for Firefox. The fix will be included in Zotero 4.0.27.
  • edited November 15, 2015
    Aurimas: yes the items are in the same library.

    Yes, you got it Dan! I've just tested with 4.0Beta and... it's working! Thanks so much! This will definitely save me a lot of time. I am amazed by your efficiency, I would have never expect this to be solved in... only 2 days! That's really great. You are fantastic!
  • I've been working this morning on Zotero 4.0beta and it is a bit slower than the previous version I had (version of zotero firefox 4.0.26) especially when I change collection and when I open a note (the heavy ones but also the light (few lines) ones).
    It's not much, at most about a second or so, but still, slower enough to be noticable.

    Not sure if the size of my library can be relevant but just in case my library contains 1500 items (parents+subitems) divided in 10 categories, the.sqlite is 14.4MB and the storage folder is 450MB.
  • That's unlikely. Nearly all the changes in the beta vs. 4.0.26 relate to save functionality. Did you 1) try restarting Firefox and 2) try reverting to 4.0.26?
  • Well you are right. I have reinstalled 4.0.26 and it seems the delay are pretty much the same. I guess I didn't pay attention to it before, but because I was on a beta, I was looking for "bugs" to report. I am sorry to have wasted you time with that.
Sign In or Register to comment.