Citation styles that include the authors' names freeze LibreOffice


When I use a citation style that include the author name (Harvard, Cell, etc), LibreOffice frequently freezes from a couple of seconds to up to around ten seconds at most. The window becomes greyed out and unresponsive during the longer freezes. When using a citation style that includes only a number (Nature, IEEE, etc), everything runs smoothly and there are no hicups. The freezing seems to be very dependent on the number of characters in the citation as including year + author causes longer freezes than only author name. Cell is the slowest citation style so far and the phenomena started at around half a page of text and 6-7 citations.

I have excluded other potential causes to this behaviour by disabling hardware acceleration and anti-aliasing and also given LibreOffice access to more memory and changed the java settings.

I wish to use Cell as my citation style, is there anything I can do to fix the freezing behaviour? I am running Zotero and LibreOffice 40m0(Build:3) from the repositories on Ubuntu 14.04.

  • Just to be clear - the whole document is so far only about a page long and has less than 10 citations, right?
    Never seen that. I wrote my entire dissertation with author-date styles. The LO add-on will start slowing down on page 100 or so, but not for an article-length manuscript.
    Particularly slow computer (netbook)? Very large database (>20k total items)?
  • edited February 6, 2015
    Thanks for always answering so quickly adamsmith!

    The entire document is now 5 pages with 15 citations, but the freezing started around length you specified. There are no images or other special forms (there was a ToC, but I deleted it).

    Fast laptop (i7 2nd gen, 16GB RAM) and small database (200 items). I thought this was related to Sandy Bridge as specified here, but I tried the suggested fixes without result and as I said, LibreOffice is working fine other than in this specific case.

    But if you haven't seen it anywhere else, I gather it is very specific to my setup somehow =/
  • I also tried this which I thought might be related, but I have no empty citation fields in my document
  • After about 20 citations and 6 pages, the freezing are now also occurring with numbered citations, but much for a shorter duration.

    Interestingly this seems to be correlated to whether I use my mouse or keyboard to navigate the document. It occurs less frequently when using the keyboard
  • so you're saying this doesn't just happen when you insert citations? This happens while you scroll? That would strongly suggest some LibreOffice issue since Zotero doesn't actually do anything unless you're clicking one of its buttons. Not sure how to troubleshoot that, though.

    You could, for the heck of it, try switching to Bookmarks in the Document prefs, see if that helps.
  • Correct, it does not happen as the citation is inserted. However, I have yet to see it in a document where I have not used zotero citation (I have not used libreoffice for longer than a month though, so maybe this is still to come)

    I tested an author-name-citation style with the bookmarks option and everything seems to work! As soon as I go back to documents pref and change it back to fields, the document hangs just after it has completed reformatting all the references. So I definitely think this is Zotero specific.

    I would prefer working with the file as .odt and the grey markup fields help me orient among the references, so if anyone can think of a fix, that would be very appreciated. I can upload the document somewhere if that helps. But the work around you suggested is great and will probably save my ass at the end of the day, thanks!
  • edited February 7, 2015
    you can use bookmarks with .odt -- you just can't use reference marks with .doc or .docx .
    The reason you'd only see this with a Zotero document would be that regular LO documents don't have long Reference marks inserted. But Reference Marks are a LibreOffice functionality, they should work properly.

    Another thing I'd be curious about: If you leave the prefs on Reference Marks, but disable "Store References in Document" - do you still get freezes (disabling that option significantly shortens the reference marks in the document).
  • edited February 7, 2015
    You nailed it!
    It's the "Store references in document"-functionality. Selecting it replicates the freezing every time. I read that it is the citation metadata that I am missing out on, exactly what effect will this have? Does not selecting it limit me to work only on a computer where I have set up my own zotero (or a shared group) if I want to edit the refs? But working with the rest of the text is fine and will not change the references when I open is on my computer again?

    I noticed that the file size varies a lot depending on my choices here.
    ref marks only...................... = 38K... Works
    ref marks + store refs in doc.. = 54K... Freezes
    bookmark only...................... = 39K... Works
    bookmarks + store refs in doc. = 56K... Works

    I do include supplements when saving citations in Zotero, but I checked all the references in this document and the biggest attachment are pdf-files of around 5-6 MB, no huge movies, spreadsheets or anything like that in case that matters.

    On a side note, the description on the bookmark option is confusing. It says "The document must be saved in the .doc format", is that for sharing with ms word only?

    Thanks for getting this to work!
  • It says "The document must be saved in the .doc format",
    I'm pretty sure that's simply a mistake and shouldn't be there. I'll double-check and fix the message.
    Does not selecting it limit me to work only on a computer where I have set up my own zotero (or a shared group) if I want to edit the refs? But working with the rest of the text is fine and will not change the references when I open is on my computer again?
    yeah, this - you won't be able to do anything Zotero related in the document without the Zotero from which you originally cited the items (of course, any synced version of that library will work).
    So for regular use, especially if your either not co-authoring or using a group to co-author, there is no functionality you're losing.

    Attachments (supplements etc.) have no effect on this--this is just the metadata, i.e. anything that'd be in the info tab in Zotero.

    This is still unexpected and shouldn't happen (and I'm pretty sure it's a LibreOffice issue), but at least that narrows it down quite a bit and gives you two pretty decent workarounds.
  • Hi

    I was looking to solve similar problem wiht Mendeley. So, this should confirm that this is a problem of LibreOffice 4.4.
  • helipiisk:
    is that on linux, too? If so, which distro?
    Also, afaik Mendeley uses code that's virtually identical to Zotero's in its LO add-on (they credit Zotero for "parts of the word processor add-on code" and I think that's particularly true for the LO one), so this isn't definite proof the problem is LO).
  • I am using Ubuntu 14.04 64bit and installed LO 4.4 from ppa or directly from LO web download. Problem is still there. I have turned off or uninstalled the Mendeleys plugin, but nothing goes better. Very annoying. The freeze only happens when I use mouse or keyboard to navigate over (or nearby) the citations.
  • There used to be a compiz problem as a result of the tooltips that LibreOffice shows when you hover over reference marks--I thought this was fixed and you're just seeing freezes, not crashes, but still, could be related.
    You could try the workaround suggested here, i.e. disable tooltips

    Again, let us know if that helps (or not).
  • Thank You!

    I disabled the tooltips and now it is working very well. Who needs the tips ?;) Hopefully this will be fixed in the future, but for me, it is fine now.
  • Same problem on Win7 Pro 64bit with Zotero in Firefox 35.0.1 and LibreOffice 4.4.03 with the Zotero integration plugin 3.5.9. My Library has just under 600 items and ca. 450 MB of attached file in /Zotero/storage. The document is 12 pages long and has just under 60 ReferenceMarks, and activated "Store references in document"-option. However, this can't be deactivated. The check-box is greyed-out for me.
  • See the tooltip advice--does that help?
  • Oh, sorry! Yes, that solved the problem. Because compiz was mentioned, I thought it was a Linux-specific advice.
  • so did I, originally, but it's (obviously) not the same issue as before.
  • Just to confirm, I also experienced this problem. delays are only on notes with lots of citations (five or more) and only when scrolling with the mouse. Keyboard, even line by line, is fine. I did not have "store references in doc" selected, and turning off tooltips solved it. The tooltips issue was definitely a libreoffice problem before. It was fixed for a while. Maybe I can check and see if anyone has filed a bug report there and do it if not. Thanks for the workaround.

    Manjaro (Arch based) linux, 64 bit. Libre office 4.3.5. Zotero 4.0.25. Chicago FUll notes. Cinnamon desktop (no compiz, no gnome)
  • FWIW, I have the same problem on Fedora, and I have filed a bug here:

    So far no reply, maybe adding "me too" comments could help getting some attention. The bug is likely trivial.

    @adamsmith: do you think Zotero could have anything to do with this, e.g. is Zotero code involved in the rendering of the tooltip? I guess not, but just to be sure.
  • edited February 20, 2015
    It's hard to say for certain, one would have to test this with some rigor, but for the specific question: no, Zotero doesn't generate the tooltips, they're a feature of LibreOffice Reference Marks (you can see that you get the same type of tooltip when inserting a cross-reference).

    But it's pretty clear that the problem are very long tooltips (that's why disabling "store references..." makes this go away most of the time, unless as with rcrath, you're looking at a big citation) which are going to be rare in cross references, so it's not unlikely that Zotero is the only software that ever generates them (but I don't know that for sure and there's obviously no reason why that should case said problem).
Sign In or Register to comment.