LibreOffice (LO) plugin not installing in LO 4.4


I've just upgrade to LO 4.4 and can't install the Zotero plugin anymore.
The error message I get is this:

( { { Message = "unknown error!", Context = ( @0 } }

The same problem is happening with a language tool


and with people using Mendley plugin as well


People at LO say this is not a problem caused by LO itself


Does anybody have any ideia about what may cause this?
I would be happy to give any help.

  • As far as I can see, all of those reports are from LO installs on linux via repository.
    The problem is LO's built-in Java (language tool and Mendeley are the two other extensions using it) and it's not the first time this would be screwed up in a repository build.
    One thing to try out would be to install LO from their (i.e. LO's) website and see if that works.
    If the poster on the Mendeley thread is right, though, and this is indeed due to a change in the API, Simon would have to take a look.
  • I just ran into the same problem. I downloaded LO 4.4 from their homepage a couple of days ago and tried to install the Zotero plugin today. Automatic install fails and manual gives the same error message as above. This is on Ubuntu 14.04.
  • edited February 5, 2015
    have you tried the solution in the first link above:
    After some more research I found out that the problem can be solved by installing the package libreoffice-java-common from repositories
    that package would definitely be needed, if it's not included in a 4.4 install that would explain the problems. I thought that came with a standard LO install on Ubuntu, at least it did for the last x versions.
    Let us know if that works.
  • I already have libreoffice-java-common (1:4.4.0~rc3-0ubuntu1~trusty1), which is the latest version from the repos. I tried removing it and installing again, but getting the same error. Tried to install language tools also, but same error there as well.
  • edited February 5, 2015
    SOLVED by uninstalling libreoffice (apt remove libreoffice-*) and then installing the latest version from the repositories. funnily I think this is the same version I had (4.4.0), but now it is working. When I restarted both language tooles and zotero was installed and zotero plugin started working after restarting the firefox and libreoffice.
  • sorry offtopic, but is there any way I can change the zotero toolbar from text to icons? Or make it smaller in any other way? It takes up a lot of space.
  • (it should be icons by default--you can search the forum a bit, there are a couple of threads on the icon vs. text issue and how to repair it, but I don't know where they are off hand)
  • I tried the complete removal and reinstalation but that didn't work... are there any other suggestions out there?
  • you've checked the libreoffice-java-common addon? And you're installing from repo or from the LO homepage?
  • Yep although the LO homepage install didn't seem to workon Ubuntu Gnome -- well it worked but nothing was installed. Anyway I added the repo from here

    Then after that was properly installed again I had to open Word, remove the existing plugin from extensions, and then install it again from Zotero. If I didn't do the last bit the plugin never loaded properly.
  • so I'm not sure I understand - do you have this working now or not?
    Also, our colleagues from Mendeley (who have the same problem) tell us that this works with the LO version installed not via ppa but directly from LibreOffice.
  • Yes sorry for not being clear. I got this working using the PPA i indicated above. For Ubuntu Gnome using the deb download package I was unable to get this to work.

    BUT the key here is that I had to remove the extension before I attempted to reinstall it through Zotero. That caused it integrate properly I found.
  • Hi Adam, well good news, I've got it working again - bad news, gaah, I have no idea what I finally did that got it working.
    I always had libreoffice-java-common installed, so we can rule that out as a possible cause (for me at least).
    I uninstalled libreoffice.
    Installed it from the ppa - that didn't work
    uninstalled it
    installed it from debs downloaded from libreoffice - that didn't work & I don't think I had gnome integration properly sorted as it looked ugly as sin.
    so installed libreoffice-common - but the addon still wouldn't install.
    unistalled everything
    installed it again - apt-get install libreoffice : nothing fancy !
    This time, the addon installed.

    That has to be the least informative set of steps : keep trying same thing, not madness, merely malicious computer gods ... so absolutely no idea what fixed it, am happy to play guinea pig further if it would help
  • well, Mendeley reported a specific bug to the LO team at Ubuntu and while the Ubuntu people don't seem to think this is the same issue for Zotero, I (and, FWIW, the folks at Mendeley) are pretty confident that it is, so my hope is that will get fixed and then fix the issue for Zotero, too. If it doesn't we can investigate further.
Sign In or Register to comment.