No translator could be found for the given file

Hi, I just exported my library to a Zotero RDF file, and chose the option to export the files as well. However, I had around 265 records, most with files, and it was taking so long to export I had to quit Firefox (which had stopped responding). Now, when I try to import my library, I get the error "No translator could be found for the given file." I do not know if this is related to the aborted export or if it's a problem with Zotero reading RDFs. Is there any way to speed up the export with files?
  • I have tried to import references from JabRef using the .bib file and also get the "No translator could be found for the given file." In fact I can't import any type of file into Zotero as it always brings up the same error message! Any help welcome.
  • Had the same problem, when I tried to import references using the JabRef .bib file.
    My sollution: I edited the .bib-file and removed the lines containig "This file was created with JabRef 2.2., Encoding: Cp1252" and any lines containing "@comment{jabref-meta: ". I was able to import the .bib file into zotero then.
  • The same here.

    After installing the latest version of zotero, I wanted to change the default library location to a location, which I can regularly backup. Unfortunately, that change did not copy or move the library to the new location. So, I had to switch back to the default. Fortunately, I found my thousands of records were still intact in there. I exported them in RDF format to a temporary location. Switched the library to a desirable location again, and tried to import the records from the temporary location.

    There was no lock-up problems that Ransomca had (see the first posting). But the same "No translator could be found for the given file." error message was displayed as I tried to import "My Library.rdf".

    The zotero documentation wrt import/export does not address this problem.


  • mehmet: Are you using the latest version of Zotero, 1.0.0b4.r5?

    While the export/import problem sounds like a bug, for what you're doing it'd be much better to just copy all the files in the Zotero data directory (inside the Firefox profile folder) to the new folder and then switch the storage location within Zotero.
  • Dan:

    Yes, my version is 1.0.0b4.r5.

    And thank you for the suggestion. It worked.

  • The same thing has been happening to me when trying to import an RDF. I've tried it on multiple workstations and always get the same error.

    Surely this has to be considered a bug
  • edited July 17, 2007
    Feel free to send files that don't import correctly to, along with a Report ID from completing Actions (gear icon)->Report Errors if the menu option is enabled after an import attempt.
  • I had the same problem when importing an .rdf file. In the error report there was written the line of the .rdf file where the error occurred. There I saw that there were some strange symbols (squares, ä€" ...) in it. So I found out that the translator had problems with ä, ö, ü, &, long -, ' and mathematical symbols. I think the problem was that we copied the abstracts directly from the pdf files. If you type ', -, <, +, >, = directly you don't have problems.
  • This is a big problem for me. I'm trying to combine Zotero files from four different computers. Once I have them combined, I'll try to synchronize the Zotero data directory, as Dan suggested on May 24. However, I can't do so until the files are combined.

    For example, this afternoon, I spent about three hours adding notes to a reference. Tonight I was going to finish up my notes for the rest of the book. So, I exported my Zotero database and brought it home. Now at home, I can't import it. On the other hand, I won't be back at the office I was in this afternoon for five days, and it's a 60 mile round trip to the office. In the meantime, I either don't finish taking notes, or I take notes using a duplicate reference and hope I can somehow merge the notes from the two versions of the reference. (Can one do this? How?)

    Also, since I'm merging four Zotero databases, keeping everything synchronized is a real problem because this bug makes the merge unreliable. For example, on Monday I might export on computer A at home and on Tuesday import on computer B. Then I work some more in Zotero on B, and export the file from B before I leave for home. Then I go back to using computer A that night. Now the first thing I should do is import the file from B because I still haven't finished merging computers C and D. But the import doesn't work. If I use Zotero on A, then I have to repeat the earlier steps of exporting and then importing on B. In the meantime, since Zotero does not yet have a Find Duplicates function, I'm replicating records. Eventually, once I do have all four databases combined, I'm looking at a day or more going through and inspecting duplicates, inspecting each, and combining versions of the same reference with different notes or tags.

    I suppose once I merge A and B I could start synchronizing their databases so that at least they are identical. Then I could do the same with computer C, and finally with D. The problem with this is that I'm afraid to start messing with phase two of the process when phase 1 has been so troublesome. If I accidentally destroy the Zotero database on one computer before all four are merged, I won't have a backup on another.

    Finally, once everything is set up, synchronizing databases is still very problematic. For example, I synchronize most of my files on the four computers using Microsoft's SyncToy and a 40GB I/O Magic USB drive. If by accident one day I forget the drive, I will be faced with the option of either not adding anything to Zotero or adding to Zotero and dealing with the export/import issue once again.

    Any help with avoiding the Translator Not Found error or suggestions for a more effective way to combine the four databases would be much appreciated.

  • These sync issues will cease to be a problem once we offer server-sync functionality, but in the meantime, here are a few options:

    1) Restart Firefox, try an import, and then send an error report to us via Report Errors in the Actions (gear) menu and post the report ID here.

    2) Try to whittle down the RDF file in a text editor until you can isolate the problematic record. Unfortunately this is a bit more difficult with RDF than with other formats with clearer delineation/organization.

    3) Send us the RDF file at, and we'll take a look at it.
  • Actually, this may be due to a bug that I fixed since RC3. Imports containing items with missing attachment files (at the time of export) failed to import. You could try to find the appropriate lines in the RDF file and remove them (or create empty placeholder files in the exported storage directory) or else try using the latest dev build, which contains the fix.

    Note that if you do that, you'll want to be sure to crossgrade to RC4 as soon as it comes out to get off the dev upgrade track before 1.0.
  • Thanks Dan.

    As an update as to how I'm handling this, I installed Portable FF on my USB drive, and I'm going to try to integrate everything into this version of FF. Once I do, I'll then use it to replace the existing databases on all four machines.

    Thanks for your suggestions. I'll try them next Tuesday, when I'm on the machine whose exported file is causing the current problem.

    While I have your ear, I also want to raise an issue on the export side. This may be more cosmetic than substantive, but it does cause confusion. Under Windows XP Pro, I have a folder, C:\My Documents\etc\Zotero. In this folder I have four subfolders, one for each computer. For example, C:\My Documents\etc\Zotero\Home. If I am working at home and right click to export my library as an RDF file, Zotero generates a file "Save As" dialog window. If I then navigate to this Home folder, the dialog really seems to want to save a folder rather than a file. Hence, Zotero creates yet another subfolder, C:\My Documents\etc\Zotero\Home\Home, which is totally unnecessary since I've already created a separate folder structure for keeping the materials from Home separately. Once Zotero creates this subfolder, Zotero navigates down one level and then will actually save the RDF file and its subfolders. The Save As dialog remains open after I press the Save button, and Zotero just drops into the second-level Home folder. Now I can enter the file name again, Home, only this time Zotero treats it as a file name rather than as a folder name. If I add the rdf extension, Zotero names the file Home.rdf.rdf. This is particularly annoying, since there may already be a Home.rdf file in the folder and by clicking on it in the Save As dialog, I can load its name (Home.rdf) in the File Name field of the dialog so that the new file will replace it. However, because Zotero adds the second suffix, the original file is not replaced.

    If, instead of this scenario, after right-clicking My Library and selecting Export, I navigate to C:\My Documents\etc\Zotero\ and then enter Home as the File Name, Zotero will find the 1st-level Home folder and drop into it. Instead of letting me create the Home.rdf (or Home.rdf.rdf) file here, when I enter Home in the File Name field a second time, Zotero drops me down to the 2nd-level Home folder.

    I think this whole set of dialogs needs to be cleaned up to work more intuitively and more consistently with other Windows applications. If the exported file requires its own folder, a few options would work. One would be to have 2 fields: Folder Name and File Name (which will be used to generate the .rdf file). Another is to automatically generate the rdf file with the same name as the parent folder. A third option would be to let the user navigate into a folder of the user's choice and have Zotero inspect the folder to make sure there's nothing in there that will cause a problem. I would not suggest erasing everything there. Eventually, I intend to use this same file structure for storing the corresponding databases. (I use this approach for critical applications so that if I forget my USB drive, I can use the application and have separate versions to merge later on.)

    Thanks for your help.

  • OK, we'll take a look.
  • Hi Dan,

    Here is the report ID: 1080349634.

    I will send the file directly to support.

Sign In or Register to comment.