Zotero Standalone sync freezes for minutes (error and debug reports included)

I've recently switched to Z Standalone (from Z for FF). Copied over my full library of 10000+ items (6000+ fulltext). Works perfectly mostly, except for sync.

Sync often causes Zotero Standalone to freeze for minutes; it often kicks in too soon, e.g. while writing notes (a problem I reported before but which I hadn't experienced for quite a long time on Z for FF); and occassionally gives unexpected errors like the following (error report #1753043929):

[JavaScript Error: "bad script XDR magic number"]
[JavaScript Error: "Error connecting to server. Check your Internet connection." {file: "chrome://zotero/content/xpcom/sync.js" line: 652}]
1419094692523 addons.update-checker WARN Update manifest for zoteroOpenOfficeIntegration@zotero.org did not contain an updates property
1419094692591 addons.update-checker WARN Update manifest for zoteroWinWordIntegration@zotero.org did not contain an updates property
[JavaScript Error: "Error connecting to server. Check your Internet connection." {file: "chrome://zotero/content/xpcom/sync.js" line: 652}]

version => 4.0.23, platform => Win32, oscpu => Windows NT 6.1; WOW64, locale => en-US, appName => Zotero, appVersion => 4.0.23, extensions => Zotero LibreOffice Integration (3.5.9.SA.4.0.23, extension), Zotero Word for Windows Integration (3.1.17.SA.4.0.23, extension), ZotFile (3.1, extension)

I'm considering now switching off automatic syncing and doing it manually every once in a while when I don't need Z right away; but obviously I would prefer if it just worked.

Sorry if this is vague, it's hard to be sure what's happening. Can run a debug session if that would help.
  • Another error report: 554310383. Again with the "Update manifest ... did not contain an updates property". I have no internet connection problems whatsoever. Am on a stable wireless connection.
  • edited December 22, 2014
    And after a restart: debug report D1028367900.

    I see many lines in the log related to the syncing of fulltext indexes. Could it be that the lag I'm getting on my system is due to the fact that those indexes are still not yet fully synced? In which case it is temporary?

    I also see many lines like this:

    File mod times are within one-second precision (1280069241000 ≅ 1280069241208) for undefined for item 0/9FFFG5AG -- ignoring
  • From the debug output, it looks like it's still processing full-text, which it will do automatically in the background.

    A manual sync will be slower, since it will check all local files for changes each time. If you leave it set to auto-sync and leave Zotero open, it will still need to check all files every few hours, but hopefully not in a way that's too noticeable.

    Could you clarify this, though?
    Copied over my full library of 10000+ items
    What do you mean by "copied" here? There shouldn't have been any need to copy anything, since the two versions of Zotero will share the same data directory by default. You might have wanted to relocate your data directory on your hard drive just to keep things straight, but that's it, and if you did it properly it shouldn't have had any effect on the program. If you did it some way other than just copying the whole data directory, that might be why you'd be seeing full-text indexing going on.
  • Thanks. I'll leave Zotero open for longer and let it autosync.

    No you're right, I didn't copy anything — I just pointed Z Standalone to my existing data directory.
Sign In or Register to comment.