new problem sync'ing attachments

can't sync attachments anymore. it was working but I tried to recover from a reconcilliation error and starting having this problem. I hit every button for sync debugging and storage debugging. have no idea what they do- they are not well documented. this is frustrating. spent a whole day trying to figure this out. this program is great ... but it can suck your time trying to figure out it 'nuances' with incomlete documentation (esp for new features).

when I verify the server, I get a -15 error box popping up. I have access to my webDAV server. if there is no zotero folder it prompts me to make one.

using 1.5r2.2 on windows FF 3.0
  • Keep in mind that you are using beta software--holes in documentation (and implementation) are to be expected.

    "Reset storage history" - Makes local sync database forget whether files have been synced or not.
    "Purge deleted storage files" - removes files on the server that you deleted locally.
    "Purge orphan storage files" - removes orphaned files (e.g. files that aren't referenced by your zotero database).

    The latter two probably won't help you. The first one might. Please follow the debugging instructions if you'd like to determine what is happening during attempted sync. At the very least, you should be able to manually delete the files from the server, reset the storage history, and sync again (pushing every attachment back to the server). (This assumes, of course, that you haven't hit storage or bandwidth limitations).
  • edited October 19, 2008
    I have a similar problem as protein function: suddenly Zotero stopped syncing attachments. It had worked without problems before and unlike protein function I had no other problems before this one appeared. Syncing the database seems to be no problem, but when I add a new attachment, the status bar doesn't appear, nor do I find the file on the webdav server. Automatic syncing and file syncing is enabled, I double checked that. Hitting Reset Storage History, as suggested above, doesn't help. Also I haven't reached any limits on the webdav server, in fact I just successfully uploaded a file to the zotero folder manually. I don't get an error message, like protein function, when I re-verify the sever.
    error # 1607744679. Here are some lines of debug output, I can send in the complete output on request.

    zotero(5): Binding parameter 1 of type int: 1224405552

    zotero(3): Nothing to upload to server

    zotero(5): REPLACE INTO version VALUES ('lastlocalsync', ?)

    zotero(5): Binding parameter 1 of type int: 1224405459

    zotero(5): Committing transaction

    zotero(3): Resetting Notifier event queue

    zotero(3): Releasing session lock

    zotero(3): HTTP POST version=2&sessionid=******** to

    zotero(3): <?xml version="1.0"?>
    <response version="2" timestamp="1224405552"><unlocked/></response>

    zotero(3): Storage sync is not active
  • I'm not sure what happened, but after I just grabbed a new item from some web page, it suddenly started syncing the attachments. It looked like it re-uploaded all of them, including the ones that didn't upload before.
    However, I then deleted the test items and their attachments, which I used for figuring out the problem described above. These attachments are now still on the webdav server and haven't been deleted as they should be...
  • Items deleted from your local checkout are not purged immediately. There is an 'about.config' setting to set the time between local deletion and purging them from the server. And you can use the proper 'storage debugging' function to get rid of them.
  • protein: -15 during verification is an unknown error. (All the error text isn't in place yet.) If you generate debug output for the verification attempt and send it to, we'll take a look.
  • After some suspicious behavior independent of zotero, I found out from my webDAV server folks (which I bought just for zotero !!!) that I had exceeded my paltry online storage limit of 100 MB. I up'ed my limit to 2 GB and the -15 error went away. My libraries are still devoid of their attachments despite downloading a lot of stuff on both sides. but the verification error is gone.
  • I'm back to where it doesn't sync attachments anymore. I guess I could keep hitting Reset Storage History like I did before, but I don't want to upload my files over and over...
    As I said I don't have any storage limitation issues
Sign In or Register to comment.