not working: getting "Invalid response from server"

  • I achieved a partial fix. The library on one computer suddenly made contact with the server and sync'd everything but other computers still got an "invalid response from server" error even when I reset their library to restore from server. So I deleted EVERY file from the offending computers' Zotero profile and replaced them with a copy of the files from the working computer. Now my syncing seems to be working again. I hope this does the trick. So far I haven't been able to make Zotero sync work for more than a week or so between major issues.
  • I'm still getting the "invalid response from server," most recently with error code 1159599822. So, unfortunately, I've still not been able to get any of my collection up onto the server.
  • I am having the same problem. Hovering over the rotating green error gives the message: "Last error: Invalid response from server".

    I am running Windows XP with Firefox 3.0.7 and Zotero 1.5b2. Any solutions on getting Zotero to sync properly?
  • Still having this problem. I have been unable to sync any files to the zotero server. I followed the steps to generate a debug report, however I'm not sure where to upload the console output. I also submitted error report # 856791343 associated with this issue. Please let me know if there is anything else I can do to try and get these files synced.
  • I am having the same error--and this feature is crucial for me, since I use lots of computers. Alas, I am an intermediate user who cannot devote a lot of time and tweaking to make this work. Any guidance is appreciated to make this work without a lot of computer science/programming-like activity on my end.
  • birkland: See Step 2 on the Reporting Bugs page.
  • Dan--Thanks. Here's the error number/bug report number

  • 1183353367
    Ubuntu 8.10, FF 3.09
    *not* using NoScript

    Similar problems to what's reported above: clicking the Sync button
    causes it to rotate for a while, some disk activity, eventually I get the "Last error: invalid response from server" yellow exclamation triangle. Going to gives me the NO_API_VERSION

    Error 1183353367 sent to Zotero
    Ubuntu 8.10, FF 3.09 -- NOT using NoScript
    as far as I can remember this behavior has occurred ever since I started with 1.5beta

    from the console:

    Error: An internal server error occurred. Please try again later.
    Source File: chrome://zotero/content/xpcom/sync.js
    Line: 1380

    Error: [Exception... "'Invalid response from server' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]

    please let me know if I can provide any other information ...

    Ben Bolker
  • PS same results after "Restore to Zotero server"
  • birkland, bbolker: How many items are you attempting to sync?
  • 2715 in my case.

    Would there be an easy way to try syncing a subset/collection?
  • any further thoughts on debugging steps? I would be happy to help if I can.
  • There's nothing to debug client-side for your error—"An internal server error occurred" indicates a server timeout, which can happen for the initial sync to the server if the server is heavily loaded. You can try at off-peak times (and once it goes through, further syncs should be very fast), but we'll be making some improvements over the next couple weeks that should speed things up.
  • Hmmm. I've tried a half-dozen more times at different times of day and over the weekend (although I'm often at home with a slower connection at off-peak times, don't know if that's an issue), with no further success (same symptoms). Takes about 5 minutes to time out.

    This is not extremely critical to me, although it would be nice if it worked for me. I am willing to wait for (server-side? client-side?) improvements, or to use a development version (eek), or to provide more info if that would be useful.
  • I am also still having this issue. I just upgraded to Zotero 2.0b3, hoping that might fix the issue, but the problem persists. I have not been able to sync my library at all. Although with the new version of Zotero, the error message has changed (when hovering over the yellow triangle): "Empty response from server" I don't know if this is any different from an "Invalid response from server".

    I have 1684 items. Is there anything else I can do to get my database synced? I'm very eager to get this working.
  • I'm getting this error ("Invalid response from server") as well with Zotero 2.0.
  • Sync is working now for me.
This discussion has been closed.