Zotero Connector no longer working for Chrome

Over the past several months, Connector functionality for Chrome has gotten worse. First it stopped showing a titlebar button (now you have to use the extension button). Then saving from the extension button stopped working normally--it only worked when you first right-clicked the button to get the menu, and then clicked on the button while it was active. Now the extension button doesn't do anything at all on any site (it doesn't seem to matter whether Standalone is open or whether any firewalls are active). I've had it record debug output but it doesn't come up with any errors; the number of lines doesn't change when I click the button (only when I update translators and load a site for the first time).

(Chrome stable 38.0.2125.111, Windows 8.1)
Would be great if this could be fixed.
  • Just to be clear--this is not a general issue. Best I can tell you're the first person to report this, so this is something specific to your setup.

    Which Zotero version? Which version of the Zotero Chrome connector?
  • Zotero 4.0.23 and Connector 4.0.21.
  • Someone will take a look addy that error report, but
    stopped showing a titlebar button (now you have to use the extension button)
    could you elaborate on what buttons you are talking about here? To the best of my knowledge, there is only one button for Zotero connector in Chrome (unless you somehow mean in the context menu)
  • Attempting to use a disconnected port object
    Usually this is due to incorrect proxy settings or third-party security software. Are you using a proxy server or security software?
  • (@Dan, that message along with "getTranslators: detection is already running" has been popping up repeatedly in Chrome for some time now on two of my computers with no noticeable consequences. It's probably benign in this case too)
  • Ah, OK. Well, the offline issue, at least, could be due to the above reasons, but aacg, you should confirm that you actually have Zotero Standalone running on your system, and you should answer Aurimas's questions above.
  • Re the title bar issue, in the past Zotero would show an icon based on the type of page in the title bar (i.e. in the right portion of the white space where the URL appears), and clicking on that would add the item to Zotero. Now it only shows it as part of the extension icon to the right of that, where the other extensions appear.

    Connector isn't working for me with or without proxy/VPN.
  • Zotero doesn't add an icon to the right of the URL bar, so that's probably not Zotero. (could you take a screenshot and link to it here?)

    It would also be helpful to see the list of extensions you have installed under chrome://extensions
  • Screenshot: http://i.imgur.com/gcamhoW.png

    Extensions: http://pastebin.com/WP0aJ8A4
  • Try disabling all extensions except for Zotero and see if it starts working. Then re-enable a few at a time until it stops. If you find a problematic extension, let us know and we'll see if there's anything we can do about it.
  • Does not work even with all extensions disabled.
  • D239845357.
    (This is after repeatedly clicking on the extension button, both normally and after right-click.)
  • No sign of anything in there after the page load.

    Best I can suggest is to try uninstalling and reinstalling the Chrome connector, and, failing that, Chrome itself. That's not something we recommend in general, but I'm not sure we've seen this before.
  • Tried both, the former multiple times. Is there a beta version I could try?
  • Iris - could you specify "the same"? Slawkenbergius has described a lot of symptoms above, do they really all apply to you in exactly the same way? (for example, do you also see the Zotero book icon to the right of the URL bar now?)

    could you try running the connector as a new Chrome user with an otherwise untouched profile:
  • New user makes no difference.
  • I'm out of ideas. I just tested this on an identical set-up (newest Chrome stable, Windows 8.1) without any problems. Also working on Windows 7.
    Either something is off with Chrome or some other software is interfering.
  • If anyone has the same problem as me, I found the solution. I don't know why this didn't occur to me earlier, but I checked chrome://flags and "Enable extension toolbar redesign" was enabled (whether by default or not I have no idea). I disabled it and everything works again, including the icon showing up in the proper location.
  • Hi, just want to say that I had the same issue as slawkenbergius and his fix worked for me as well.
  • Bizarre..Following above advice, in my Chrome "Enable extension toolbar redesign" was already enabled. Disbling did nothing, but then re- enabling it made the Zotero icon appear, where it had not been seen before. But only faintly, with no function
  • Which version of Chrome? What OS? Try disabling all other extensions.
This discussion has been closed.