Edit journal abbreviations

For the most part Zotero does a great job with journal title abbreviations. However for some specific journals the "full" title is imported which is far too long. Some examples follow:
  • The Spine Journal: Official Journal of the North American Spine Society

  • European spine journal: official publication of the European Spine Society, the European Spinal Deformity Society, and the European Section of the Cervical Spine Research Society

  • Journal of orthopaedics and traumatology: official journal of the Italian Society of Orthopaedics and Traumatology

  • Journal of clinical neuroscience: official journal of the Neurosurgical Society of Australasia

  • Journal of bone and mineral research : the official journal of the American Society for Bone and Mineral Research

  • Movement Disorders: Official Journal of the Movement Disorder Society
Clearly anything after the initial journal title is unnecessary information and should not be included in the citation.
I generally get all my references straight from PubMed and for whatever reason when I create a bibliography these journals will abbreviate using the long title.
I almost always use the Vancouver (superscript) style.

Is there any way to edit the built-in list of journal and word abbreviations in Zotero?

Alternatively, can we instruct Zotero to not incorrectly import the full title of some specific journals?

As a third option, can we fix some styles to use the journal abbreviation field preferentially, rather than abbreviating the full journal title field?

Thanks for your help.
  • This has come up before, not sure where we left this off.

    For 3. You can toggle the behavior (automatic abbreviations versus using the Zotero journal abbr. field) under Set Document Preferences in the Word/LO plugin.
  • edited November 6, 2014
    Thanks adamsmith. Yes I'm aware of that feature, however I'm under the impression that it will then only abbreviate if journal titles are specifically in the list that you create. I'd rather have the feature first check that list, then if the journal is not there, revert back to the default Zotero abbreviation system. As it stands currently, checking that option supplants the default Zotero abbreviations entirely, which is undesirable IMO (unless I'm mistaken about all of this).

    Also sometimes there are minor discrepancies in the imported journal title name, such as aberrant spaces, capitals or lower-cases, etc., and in those cases the abbreviation will be missed.
  • you can't do that, no.

    But to clarify: it doesn't check a list, it just checks the field in Zotero (and if nothing is there, it does indeed just use the full title).

    Editing abbreviations is theoretically possible, but relatively involved. See Simon's comment here and subsequent discussion:

    You may also be able to use fbennett's abreviations filter add-on.
  • edited November 6, 2014
    I see. Yes that option would be helpful.
    To revise my original comment then, I'm under the impression that if the "Journal Abbr" field is empty, it will use the FULL title rather than applying the "Automatically abbreviate journal titles" feature.
    It would be preferential IMO to check that field, and if it is empty, still use the automatic abbreviation schema (i.e. rather than turning that feature on or off completely).
  • no, I don't think we'll want to go that way. There are disciplines (Theology, e.g.) with entirely different abbreviation rules and that would mess with those terribly. Too many options aren't good, either, so the way to go would be to either fix this in the abbreviation alogrithm (just chop of the part after colon) and/or to fix this on import from pubmed (which is pretty much the only place that has these). I'd recommend deleting them in your data for now.
  • Either of those solutions would be acceptable and preferable.

    Yes currently that is what I am doing but often I don't notice until far into the manuscript creation process and it's a pain to go back to my library and search for them.

  • @dryphi: You could also try installing this plugin:


    If it doesn't work for you, you can just disable it.
  • Hi, sorry to drag up an old post, but did this problem ever get resolved?
    I still see ESJ importing as "European spine journal: official publication of the European Spine Society, the European Spinal Deformity Society, and the European Section of the Cervical Spine Research Society" which I must go into my library and edit manually.
Sign In or Register to comment.