Zotero becomes unresponsive for a long time on startup and also during use

Zotero (both standalone and firefox) is unresponsive for 6 to 8 minutes upon startup. It also becomes unresponsive frequently during usage (not clear what triggers this).

While unresponsive and when I try to close the standalone, the following message appears: XULRunner is not responding.

During startup, the following bug reports were generated:
For standalone, the Debug ID is D1418430470
For firefox version, the Debug ID is D556014711

I also noticed that while the standalone was trying to open, that firefox would not open until zotero became responsive again.

Both versions of Zotero were working fine. The problem started after I tried two firefox addons for keyboard shortcuts (VimFx and Vimperator). VimFx appeared to cause freezing when zotero (firefox) was started. I disabled VimFx, which oddly was unsuccessful, so I then removed it. After removal, Zotero appeared to perform normally.

I then installed Vimperator and, at first, Zotero performed normally. Afterwards, when the problem started, I removed Vimperator, but the problem with Zotero continued. Firefox appears to be working Ok.

While Zotero firefox is opening, usage of RAM by firefox sometimes increased dramatically (from about 300 Mb to 1 or 1.5Gb), then decreased again.

Finally, I´m using Windows 7 Home Premium, 64-bit / Firefox 32.0.3 / Zotero 4.0.22 (firefox and standalone)

I would greatly appreciate help. Thanks!
  • Closing the tag selector will fix this, but we haven't been able to reproduce this slowness, so if you notice some way to consistently reproduce slow vs. fast behavior with the tag selector open, let us know.
  • Thank you for your quick response.
    Indeed, closing the tag selector fixed this, but, so far, once Zotero is open, my attempts at opening the tag selector have more often than not caused Zotero to freeze (both versions). I have become quite dependent on tags and have always kept the selector open. I guess I need to figure out work arounds.

    Just a while ago, firefox gave me a message that it seemed slow and suggested that I consider a reset to fix possible problems (another new event). Since the standalone version appears to use some resources in common with firefox, I wondered if a firefox reset might return my zotero back to the way it was.

    Think it would work? I don´t mind if I have to reinstall extensions or reconfigure a few things if zotero returns to its former performance.
  • We don't know — this is a recent regression of some sort, but we haven't been able to reproduce it, and people who are experiencing it have had it on some computers and not others with the same library, so it seems to be something specific about a given setup.

    What might be helpful is if you would install a few older versions of Zotero for Firefox to see when it started:


    If it happens in, don't bother with the others.

    (Also, we don't recommend using an older version — this is just to help us narrow down the cause. )
  • Ok, nothing that I tried worked (resetting firefox, reinstalling standalone and firefox, version, going back to a recent restore point).
    However, later at home (I use a laptop) the problem went away (!?).
    This morning, at work, back again (!?)
    I can now reproduce the problem. It really seems odd, but each time I connect or disconnect a pen tablet, the problem arises or goes away. I´ve now done this several times, with same results. If Zotero is opened while the tablet is connected, it freezes. If Zotero is first opened, then the tablet is connected, it seems to be ok and I haven´t observed any problems so far.
    This will happen with both a Genius and a Bamboo (Wacom) tablet (installed these a few days ago for specific project).
    Both tablets make an icon appear in the taskbar, which when clicked opens a "pen and touch" settings window (which I think is from Wacom) and the following processes appear in task manager (or disappear when the tablet is disconnected)
  • Wait, really?

    When you say it freezes, are you sure you mean freezes with the same issue — i.e., a load of a collection takes a very long time but finishes, and it's fine with the tag selector closed — or does it just freeze and not come back whether or not the tag selector is open? If the latter, that'd be a separate (and more plausible) issue.

    If it's really the former, can you provide Debug IDs with and without the tablet plugged in? Does plugging in the tablet have an effect on CPU or disk usage on the system in general?
  • edited October 8, 2014
    Yes, really. And totally reproducible.
    Sorry, when I said freeze, yes, I meant the same issue: zotero becomes unresponsive for several minutes while opening, but eventually loads and becomes responsive. This only happens when the tag selector is open. Its fine with the tag selector closed - but after I open zotero, if I then open the tag selector (using ctrl+shift+T), it often becomes unresponsive for several minutes.
    This all happens only when the tablet is connected to my laptop. When disconnected, there are no issues, as far as I can tell. Zotero opens normally and there are no problems while working with it (regardless of the tag selector open or closed).

    Plugging in the tablet has virtually no effect on resources. CPU usage will go up for a few seconds but go back to 0-2% (idle). Memory practically does not change. The processes I mentioned above take up 1 to 4,5 Mb each (roughly 14 Mb total). I don´t know where to look for disk usage.

    When you asked me to generate a debug ID with the tablet disconnected, I thought it would be empty, but not so. Below are the debug IDs under several conditons:

    a) Tablet disconnected / opened zotero with tag selector open - Debug ID is D465108654

    b) Tablet disconnected / opened zotero with tag selector closed - The Debug ID is D1455065994

    c) Tablet connected / opened zotero with tag selector closed - Debug ID is D1650491054

    d) Tablet connected and opened zotero with tag selector closed / then opened tag selector after zotero was loaded - Debug ID is D2119879869

    e) Tablet connected / opened zotero with tag selector open - Debug ID is D106149894

    As for the Debug output, I clicked on "enable after restart" for a, b and c. For d, I first opened zotero, then enabled debug right before opening the tag selector. For e, I had to enable the debug in the previous section and I also clicked on "enable after restart", otherwise, only clicking on the latter did not enable the debug.

    Finally, neither VimFx or Vimperator have this effect on Zotero as I stated above. It was all due to the tablet being connected (or not).
  • Wow. That's…insane. We're looking at 1 second vs. 7.5 minutes to load the tag selector depending on whether a drawing tablet is plugged in.

    So when the tag selector is enabled, Zotero draws thousands of extra UI elements on the screen, one for each tag. If I had to guess — which I do, because this is quite possibly the strangest bug we've ever seen — I'd guess that either Firefox or the Windows tablet services are doing something (badly) to make each tag label accessible via pen input.

    I've asked in another thread whether a person experiencing this is using any sort of unusual input device — we'll see what they say. But what I'd suggest is playing with the Windows tablet settings to see if there are any specific features that you can disable that make a difference.
  • I don't know if this comment will help, but I've noticed Zotero (standalone version) becomes unresponsive on my laptop, which has a touch screen, but it works fine on my desktop and old laptop. All my systems are running current, updated versions of windows 8.1 and Zotero (whatever is current as of 15 Oct 2014).

    On my laptop (Acer S7 392 with touch screen, 8GB RAM), every time I open zotero it become unresponsive for a minute or so. Then becomes usable, but freezes periodically whenever I browse a new subdirectory or enter a search term.

    I also have TabTip.exe and TabTip32.exe active in my task manager.
  • You could try disabling your touch screen's input, as described here: http://www.intowindows.com/how-to-quickly-disable-touch-screen-input-in-windows-8-1/ (at your own risk)

    If that solves the speed issue, it would confirm the source of the problem.
  • Hi Rintze, thanks for the suggestion. I found that closing the tag viewer also "solves" the problem.
  • Yikes. OK, well, I don't exactly have a way to reproduce this myself, but I guess we'll try to track down a touchscreen PC or drawing tablet and see what we can do — though unfortunately the bug is likely upstream, so we may only be able to report it. Thanks for confirming.

    (And yes, the tag selector is the direct trigger in Zotero, so closing that is the short-term workaround, but the problem is in the Windows touchscreen services or Firefox's interaction with them.)
  • Was this issue ever resolved. I had a huge library on my Standalone desktop, and recently uninstalled and reinstalled drivers for my Wacom Bamboo Pen and Touch. I did not need or open Zotero until over a month later, and I had it set on auto sync. When I opened Standalone, my entire library was gone, though it is still online. I turned off the tag selector (which was empty). When I try to sync (left it overnight), I come back to "Processing updated data from the sync server", but if I over the pen tablet over the window, it then says "not responding". Stopping and restarting reveals no updated materials in the library.
Sign In or Register to comment.