Uploaded data not well formed

Hi Zotero,

I have trouble syncing my library (~ 900 entries), I am getting a
"Uploaded data not well-formed (Report ID: 9b060d6323)" error.
I have reported the error under the id 40279905
I have also uploaded a log file of an attempted upload under the idea D2057306663

I would be glad if you could help!

I have tried setting purge tags to true, as well as checking integrity of the database (valid).
  • You have a whole bunch of dateAdded values with decimal places:

    dateAdded="2014-03-14 11:21:06.000000"
    I'm pretty sure you would've had to have modified your database yourself (or used a third-party add-on that did so) for that to happen, in which case I'm afraid you're on your own here.
  • That is indeed true, I imported Mendeley data by hand..
    I have now corrected the entries in the zotero.sqlite but apparently zotero is still trying to upload the old data (I can see the old entries in the log).

    Is zotero caching the upload data? Can I somehow reset the cache?
  • Ah, nevermind it worked now. I had changed my data directory.
    Thanks for the hint!
  • shameless plug: just to let you know, the tool I used to mess up my db (now fixed) is here: https://github.com/flinz/mendeley2zotero
Sign In or Register to comment.