Stop indexing pdf as soon as they are added

Today Zotero starts to index a pdf as soon as you add it to your library.

This behavior slows a lot Zotero. And it happens just as the exact time you want to modify (often) the fields of this new entry.

I propose Zotero index pdfs on a customizable schedule (for example : every 24h) or to pause indexing when doing something in Zotero (in order to save memory and reactivity).
  • As I understand it, asynchronous indexing and other database operations (which will not cause Zotero to freeze while it's "doing stuff") are going to be the main feature of the next major version.
  • Thank you for your quick answer. Nice to see these features coming!
  • Meanwhile, you can disable pdf indexing by changing Maximum characters to index per file to 0 and also max pages to 0 in Preferences/Search.

    This allows you to add pdfs without a delay.

    Then, at somepoint when you choose, reinstate the indexing numbers that you changed and then click on Rebuild Index/Index Unindexed Items and it will index the new pdfs.

    It would be nice if there was a check box to disable indexing without having to change the numbers, but this isn't too bad.
  • This is really helpful. But this only stops indexing pdf files. But when importing a large number of .txt files or .html it continues indexing and it hangs. Is there any way to stop indexing of all kind of files? Thanks in advance.
  • It's a bug, but max characters actually has to be set to 1, not 0.
Sign In or Register to comment.