Right click > "Show file" try open wrong path (Linux)

Lets say my PDF file is in '/home/user/.zotero/zotero/ltzriw89.default/zotero/storage/2V82AFQS' directory. When I press mouse right click > "Show file", it opens default KDE4 manager Dolphin, but with error saying, that trere is no such directory:

Seems, that Zotero try open $HOME'$PATH_OF_FILE'/ instead of $PATH_OF_FILE.

I remember, that few months ago (maybe 2014 May) this function worked well in Linux.

Zotero report ID: 1332222037
  • What distro is this, and are you using the Zotero tarball or a package? (If a package, try the tarball.)

    File revealing on Linux is a complete mess, but no one else has reported this. A Debug ID from the reveal attempt might tell us a bit more (at least in terms of which of the many possible methods it's using).
  • Thanks for replay. Now I use openSUSE 13.1 32-bit version. I use Zotero, that I extracted from TAR.BZ2 archive.

    I send debuging message after trying two times open folder of the same PDF.
    Debug ID: D725430646
  • Yeah, so Zotero is just calling file.launch() on the parent directory. This is likely some sort of incompatibility between XULRunner and openSUSE.

    Have you tried this in Firefox with Zotero for Firefox (which will share your existing data directory by default, so it's easy to test)? If it fails there we can also give you some additional code to debug this.
  • If I try this in Zotero for Firefox (not in Zotero Standalone), it works fine!

    Debug ID D503747417
  • That's Firefox 31.1.0 (ESR, I think?). Can you try this with a copy of Firefox 32? (The tarball is probably fine if you want to stay on the ESR otherwise.)
  • Yes, now i use 31.1.0 ESR. I will try.
  • M B
    edited October 4, 2014
    With Firefox 32.0.3 it can not open folder.
    It try to open

    where /home/[user]/Siuntiniai/firefox/ is folder, containing Firefox 32.0.3 binary

    Debug ID D971697944
  • OK, so this is a regression in Firefox/XULRunner 32, then. You should try, in order until it works, Firefox 33 Beta, Firefox 34 Aurora, and Firefox Nightly, so we know whether this has already been fixed.
  • A, I see after executing
    > ./Zotero_linux-i686/xulrunner/xulrunner -v
    Mozilla XULRunner 32.0 - 20140825202822

    So I wish you to build Zotero based on stable ESR releases!
  • There's nothing "stable" about ESR when it comes to bugs. ESR just means it gets security fixes. If this bug had been in Firefox 31, it would have lasted for a year in the ESR.

    Newer releases have performance and security improvements, and most people using Zotero for Firefox aren't using an ESR, so we develop primarily for the non-ESR releases and try to maintain compatibility with the latest ESR release.
Sign In or Register to comment.