Zotero Standalone 4.0.22 very slow to open library in Windows 8.1 - PAUL'S

@Dan Stillman:
I believe my Zotero problem to be the same as andrecs (symptoms appear identical) so I posted to the thread he started. I believed that to be most useful for all.
- Since recently (last few weeks), EVERY TIME I open Zotero, it takes WELL OVER 1 HOUR to open, even if it was working well immediately before closing last time.
- For example, after starting overnight Zotero was stable. I closed it today, restarted Zotero and now it has been 1h and it is still "not responding" ("Loading Item List..." is displayed in a blank center panel.
- Auto sync is OFF.
- I am using cloudme.com as my WebDAV sync server (so I would think my limit on the Zotero server is not relevant). BTW, I can support Zotero development some other way.
- I haven't moved the data directory, though I did reinstall some time ago.
- I am trying to get some debug data for you.

Thank you for your help.

Reply from Dan Stillman:
protein function: No mystery — your client was performing a full download of your very large library, and you were force-quitting it before it could finish. As for why it was doing a full sync, that's hard to say, but could've been something you did (new install, moved data directory, Restore from Zotero Server) or one of a few rare situations during normal usage where it can be triggered automatically (which will go away with the new syncing architecture in the next major version of Zotero).

Separately, you're also at your file sync quota, which can cause (lesser) delays, so you should increase your storage subscription, delete files and empty the trash, or disable file syncing. For further questions, better to start a new thread, since this one is for andrecs.

My first comment:
I am monitoring this thread closely because my Zotero Standalone (Windows 8.1) is nearly DEAD IN THE WATER for about a week now (upon attempting Zotero startup with persistent "Loading items list...", Zotero Not Responding and XUL Runner is Not Responding messages). I believe it is Zotero Standalone 4.0.22 but can't be sure (can't open the program). I have spent >5-10h rebooting, force quitting, reinstalling, waiting >>30 minutes to no avail etc. etc. INEXPLICABLY, I have had Zotero up and running once in the last week. But, again it is back to Zotero (Not Responding). I have disabled auto sync and the problem absolutely persists. Will try the debugging workflow (www.zotero.org/support/debug_output) next time I get the program to open. Very frustrated. My library is 6754 items.

UPDATE: After writing the message above last night, and with Zotero "greyed out" and displaying "Zotero (Not Responding)", I retired for the evening -- but left Zotero running as recommended in another post above. Indeed, the next morning Zotero was running normally. So, waiting is effective to heal the unhappy Zotero, but the slow startup is annoying. I will start debug so that next time I can provide some actionable information.

Update 2: One thing I notice is that in Task Manager (Windows 8.1), Zotero when running stably (e.g. now) is using an unchanging 182.7 MB. Last night when Zotero was opening up but not responding, Task Manager indicated it was using >250MB and STEADILY incrementing by 0.1MB. I believe it was up to >300MB when I walked away. This behavior in Task Manager has accompanied all my apparent Zotero 'freezes'. I don't know if this is relevant.
  • After shutting down Zotero Standalone that was working after very slow startup (e.g. was not a force quit), the next time startup of Zotero took about 1.5h on my i7 Windows 8.1 machine. The Debug ID is D1099326329.


  • I am using cloudme.com as my WebDAV sync server (so I would think my limit on the Zotero server is not relevant). BTW, I can support Zotero development some other way.
    Dan would have to speak to most of this, but I'm pretty sure he wouldn't have mentioned this if you weren't actually _hitting_ the file storage quota. Remember that you can only use Zotero storage for group file storage, so if you own any groups that would still be relevant even if you use webDAV for items in your library.
  • The Debug ID is D1099326329. Thanks
  • Dan would have to speak to most of this, but I'm pretty sure he wouldn't have mentioned this if you weren't actually _hitting_ the file storage quota.
    No, sorry, I was actually just looking at the online stats. So if protein function is syncing with WebDAV, that's irrelevant as long as syncing is off.

    So I assume the issue is this:
    (5)(+0000001): SELECT tagID FROM tags WHERE name=? AND libraryID IS NULL

    (5)(+0000000): Binding parameter 1 of type string: "_tablet"

    (5)(+6250893): SELECT tagID, name FROM tags WHERE tagID IN (SELECT tagID FROM itemTags WHERE itemID=?)
    That's a delay of over 100 minutes, for what should take approximately a second or two. (It's not necessarily about the _tablet tag in particular.)

    So, first, I'd guess that closing the tag selector in the lower left corner (dragging down from the line above it until it closes, or clicking the little dot in the middle) will fix this. We've had a few reports recently of slowness with the tag selector open with libraries with many tags, or tags assigned to many items.

    But since I haven't been able to reproduce this, can you check how many items you have in your library, both in My Library and also in the trash? Did you make local changes before this started occurring (e.g., importing many items, adding a tag to many items)?
  • Also, can you provide a Report ID (different from a Debug ID)?
  • Report ID: 1299674899. Thanks.
  • You didn't address any of my other comments.

    Also, does this still happen if you disable ZotFile? (It quite likely will. I don't know that ZotFile actually does anything that would have an effect on performance.)
  • edited October 3, 2014
    Tag selector: I did try to close the tag selector but I did not understand how to make this selection "stick" after I restart. Even if I had the tag selector closed, restarting was extremely slow. I did not notice a benefit, but am not sure I did this correctly.

    My library is 6757 items. Trash has 17 items.

    Today I noticed three add-ins:
    1. Zotfile 3.3
    2. Zotero Word for Windows Integration 3.1.17.SA.4.0.22
    3. Zotero LibreOffice Integration 3.5.9.SA.4.0.22

    I disabled all 3, and Zotero started quickly for the first time in weeks!! Then, I reinstalled them sequentially, followed by restarting Zotero. Reinstalling Zotfile alone did not break Zotero, nor did then adding the Word add-in also, nor then the LibreOffice add-in also (which I don't actually need). I have repeated restarting Zotero numerous times and it is fixed. I hope there are some clues, despite my inability to reverse the apparent fix. In any case, I am thrilled to have Zotero back working correctly (though waiting for 100 minutes while Zotero Not Responding was a useful workaround -- better than force quitting and being unable to use Zotero).

    Please let me know if there is any other troubleshooting I can help with.
  • could you confirm that you have ZotFile 3.3 running again now, not an earlier version (e.g. the 3.1 version downloadable from mozilla).
  • Yes, it is Zotfile 3.3 and it is running and functional.
    I just reconfirmed and used Zotfile functionality to send a PDF to my tablet. I just reconfirmed that Zotero is starting briskly.
    One thing I just noticed is my tag selector is now closed (though it had been open I believe). I wonder if that is involved in fixing my Zotero?
  • > One thing I just noticed is my tag selector is now closed (though it had been > open I believe). I wonder if that is involved in fixing my Zotero?

    Seems that opening up the tag selector has broken Zotero. It is now not responding. I will wait up to 100 minutes and try to restart and see if this problem persists through startup or is just a one time thing.
  • Tag selector is a bad player on my installation. I opened Tag Selector up and got 1) No Tags to Display (I guess it needed to find all tags) and 2) Zotero not responding. Left Zotero for >7h and it had not become responsive. Quit Zotero. Restarted Zotero. It did come up fast with tag selector collapsed. When I opened tag selector. Got No Tags to Display and Z non-responsive. I force quit. Restarted Zotero. It did come up fast again with the tag selector collapsed. Trying to understand how this is reconciled with my apparent fix by turning off all add-ins (or was that also via the tag selector?).
  • Trying to understand how this is reconciled with my apparent fix by turning off all add-ins (or was that also via the tag selector?).
    It's possible/likely it had nothing to do with disabling ZotFile and was just the combination of turning off the tag selector and restarting, as opposed to either of those things alone.
  • But I'm still not able to reproduce this myself.

    To try to figure out if there's something specific to your installation, could you go to your Zotero profile directory, make copies of prefs.js and localstore.rdf, and then delete the original files and restart Zotero? (Your Zotero preferences and window settings will be reset, though you can copy the original files back after if you want.) I'm curious to know whether the problem goes away with the tag selector enabled after that.
  • edited October 3, 2014
    AT FIRST, I archived prefs.js and localstore.rdf, then deleted these files, and restarted Zotero. Z started quickly with the tag selector closed. It appeared I am now able to open and close the tag selector without breaking Zotero. It SEEMED fixed. Also, Zotero seemed quicker. BUT then I selected a tag. At first this worked (two entries appeared). Then I deselected tag . This appeared to work (all entries came back). But, then Zotero became non-responsive. Now Z tried to open with tag selector open and Z is non-responsive. When I either 1) restart or 2) delete prefs.js and localstore.rdf again and restart this non-responsive start persists. If I copy back my archived prefs.js and localstore.rdf, Z opens with tag selector shut and the program works great and seemingly robustly (except tag selector or tags?). I am operating with my old prefs.js and localstore.rdf files which somehow seem to have been healed by some combination of 1) disabling/re-enabling add-ins, 2) closing the tag selector and 3) restarting Z.
  • So forget about ZotFile and forget about prefs.js/localstore.rdf. It sounds like the only thing so far that actually has an effect is restarting Zotero.

    I'm afraid we really need a consistent set of steps to reproduce and not reproduce. It will almost certainly always be fast after restarting Zotero with the tag selector closed. What we need to know is how you can repeatably, reliably cause it to be slow from a fresh startup, and we need the precise steps that takes, including exactly what's selected in Zotero and how many items are in it, what you click on, etc.
  • edited October 3, 2014
    Have you tried checking Database integrity yet (may have missed it in the replies)? Preferences -> Advanced -> Files and Folders -> Check Database Integrity. Either way, it may help if you upload your database to the database repair tool https://www.zotero.org/utils/dbfix/ so that Dan can maybe try to reproduce the issue with your setup (since it doesn't seem to be specific to anything in prefs.js or add-ons you have installed)
  • Dan: I will forget about Zotfile and prefs/localstore. I will try to be very specific about exactly what I do.

    aurimas: I checked database integrity. Errors were found and corrected (inside Zotero). Subsequent check finds no errors.

    After database integrity correction (as above): I restarted Zotero. Tag selector was closed. Upon opening tag selector, Z becomes non-responding.
  • Right, but we need more than that. We already know that having the tag selector open can cause this — that's why I suggested closing it in the first place. But it's obviously not just that, or else many more people would be reporting it and we would be able to reproduce it. What matters is why it can sometimes be open without the slowness. And since you can reproduce this and we can't, to fix this we'll need your (or someone else's) help in figuring out what's different between when it's slow and when it's not.
  • So this is an extreme long shot, but you don't happen to have any sort of unusual input device (e.g., drawing tablet) plugged into your computer, do you? (We've had another report of this, but it happens for that person only when a tablet is connected.)
  • Or have a touchscreen monitor?
  • I am having a similar issue, and I have a touch screen monitor (Acer S7 392). Zotero works fine for me on non-touch screen machines. When tag selector is closed, it seems to work fine on my touch screen laptop. When tag selector is open, Zotero becomes unresponsive for a few minutes if there are a lot of tags in the subdirectory I am viewing.

    I think Dan's extreme long shot is correct. I'm currently waiting for Zotero to unfreeze so I can report my debug ID.
  • my debug ID is D1820868789.

    I am pretty sure my issue (on a touchscreen i5 laptop with 8GB RAM) is the tag viewer. Zotero was running fine. I opened tag viewer and it became unresponsive. I ended the task and restarted Zotero and it is working fine with the tag viewer closed.
  • OK, protein function, if you're not in fact using a touchscreen PC or drawing tablet, let us know here, but otherwise we can continue this in the other thread. Thanks to Rintze for the brilliant touchscreen monitor suggestion and sokole for confirming.
Sign In or Register to comment.