Conflict with FF 32 bookmarking

Hi there,

I am using Zotero Standalone on Arch Linux. Additionally I installed the Firefox add-on from here [1] to be able to save online resource to my library from within Firefox.

However, I encounter the issue that with the add-on being enabled, I cannot edit my bookmarks. I click on the star [2] but no window is showing up as it is supposed to do.

Can someone confirm this?

Thanks ahead!


  • Works for me.
    To be clear--the first time you click the star it just adds a bookmark, it doesn't open a window, but I assume you're aware of that. If you click the icon next to the star, do you get the context menu with bookmark options?
  • Yes, I am aware of that.

    To confirm, clciking on the icon next to the star opens the context menu. However, clicking on the star once the bookmark was added used to open a small popup where I was able to edit the bookmark.
  • and you've confirmed that disabling Zotero fixes this problem?
  • It would be very strange for this to be caused by Zotero, but I suppose all bets are off on Arch Linux.

    Can you provide a Report ID after reproducing this?

    And also, can you just confirm that you can repeatedly enable Zotero, restart Firefox, reproduce the problem, restart Firefox a few times and still reproduce the problem each time, disable Zotero, restart Firefox, not reproduce the problem, restart Firefox, still not reproduce the problem, reenable Zotero, restart Firefox, reproduce the problem, etc.?
  • @Dan

    You were right. It was an Arch related issue.

    The Firefox package has just been updated [1] and also fixed the incompatibility of bookmarking with Zotero.

    Thanks for your help!

  • And the issue is back again.

    Once Zotero is enabled, I cannot edit any existing bookmark.

    Installed version: firefox 32.0.1-1

    Should I finally report this to the Arch Linux bugtracker or can someone using another distribution reproduce the issue as well?
  • I'd try to sort this out on the Arch side of things. Still works for me--and always has--on Ubuntu.
  • Need to re-open the discussion. I tested Zotero on a Window machine with exactly the same problem. Once Zotero is installed, I am unable to edit my bookmarks. However, I can still add new bookmarks.

    I tried already cleaning places.sqlite and did a completely reset of my Firefox browser. All without success. The only thing that works is removing Zotero.

    Can nobody reproduce this issue?


    Windows 7
    Zotero 4.0.231
  • Any themes or other add-ons that you consistently use that could cause this? Can't replicate this on Windows 7, either.
  • I think I have found the conflicting add-ons: Zotero and Xmarks [1].

    Can you please test if you can reproduce the issue with having both installed?


  • As a workaround the following steps work and allow me to edit a bookmark:

    1. Bookmark a page, e.g. by clicking on the star
    2. Go to Bookmarks -> Show all bookmarks
    3. Search for your bookmark
    4. Now I am able to edit Name, Location or Tags
Sign In or Register to comment.