Word 2011-Mac Impossible to insert bibliography

Hi
I've looked around for a similar post but couldn't find any.
I use word 2011 and Zotero add-on on Firefox on Mac.
I try to insert a bibliography on a big document (440 pages, my completed dissertation) which has a huge amount of in-text zotero citations.
That document was formed by a copy-pasting of other documents (the Chapters of my dissertation). All documents had the same zotero citation style and document preferences.
When I click on "Insert Bibliography", nothing really happens, except Firefox freezes for a while and then gets back to normal after 20 seconds or so.
Does anybody have any clue of what I should do. This is pretty urgent since it is the final month before submitting my dissertation ?
Thanks in advance for your help!
  • When you copy-pasted, did you paste _with_ formatting? Seems like the field codes did not copy over. See if you can position the cursor on an existing in-text citation and then edit it using Zotero's Edit Citation button.
  • Also, try setting a citation style in the new document via "Set Document Preferences"--ideally before pasting, though I'm not sure that matters.
  • Hi,

    I have tried what you advise -- i.e., setting document preferences beforehand, and making sure the field codes where copied either. When I click on the item cited in the text, the gray thing appears which means that they were indeed copied. Yet, the same problem occurs.
    It seems that trying to put together such a big document has kind of messed up my zotero / word integration plugin. Indeed, inserting a bibliography does not work properly even when I try to do so on a smaller document. Moreover, the zotero citation editor, which used to be the new red editor, is now the old-school big citation editor. This is very bizarre. I have tried uninstall zotero and the word plugin from firefox with no success. I am kind of lost and need your help again!
    Thank you in advance
  • Have you tried different citation styles?

    You should be able to get the red-framed dialog back by unchecking "use classic add citation dialog" in the Cite tab of the Zotero preferences.

    Beyond that, provide an error report ID from Zotero after trying to insert a bibliography in a very simple document (ideally just one citation).
    http://www.zotero.org/support/reporting_bugs#provide_a_report_id
  • edited September 10, 2014
    I have installed Zotero standalone, added the Word integration and been able to insert the bibliography after the first chapter, and then merge two more chapters (and refresh the bibliography using "zotero refresh" every time I copy-pasted a new chapter)
    Yet, when trying to merge the fourth chapter, "zotero refresh" doesn't work. Nothing really happens, even if I wait for 10 minutes. When trying to press "zotero refresh" again Zotero standalone appears, but nothing happens in my word document.
    As far as the intext references are concerned, they're ok and I can add and edit citations even though it takes some 10 seconfs for zotero.
    I have a report ID from Zotero after having tried to refresh zotero when copy-pasting the fourth chapter
    The report ID:
    231594342

    Thanks again for your help
  • Can you insert a bibliography for just the fourth chapter?
  • @Dan - anything in the error report?
  • [JavaScript Error: "Error loading style '_.csl': Zotero.Utilities.xpathText(...) is null" {file: "/Users/[...]/Documents/Storage/styles/_.csl" line: 446}]"
    Probably a bad ID on a custom style, and possibly a bad custom style in general.
  • Yes. I have this new error report
    127987332
  • I indeed use a custom style. I spent hours making it. I used a csl validating websites to make sure it was ok. But it might be linked to that.
  • If the filename is _.csl, the id is at least wrong. Delete that file from the 'styles' directory of your Zotero data directory, fix the id, and reinstall it and make sure it gets a correct filename.

    There may be other problems too, but start by making sure it gets a valid filename after installation.
  • There's a problem with its ID, which looks like it's empty or corrupt or so.
  • Check the file at the path in Dan's post. If that is your custom style, validate it again against http://simonster.github.io/csl-validator.js/, make sure to give it a unique ID and rename the file for posterity. If that style is not necessary, delete the file.

    Though I'm not quite sure why that would make a difference when merging documents if everything works fine in separate files.
  • Aurimas is buying the drinks tonight :P
  • I'm sorry, but I don't know what "changing the ID of my csl file" means. Does that mean I have to name the csl file some other way ? Does that mean I have to write something in the csl code itself?
  • If you open the file in a text editor, it will become pretty clear. It will be towards the top and look something like <id>http://www.zotero.org/styles/my-custom-style</id> "my-custom-style" part is what you want to change.
  • I just did what you said, changed the id, and replaced the csl in my zotero directory. But when I drag the csl file on firefox, nothing happens. Is that because I now use Zotero standalone?
  • close down standalone. Then try again.
  • But also, if you edited the file in place (without creating a copy), you don't need to re-add it to Zotero. Just restart Zotero afterwards.
  • It seems to be worth. When I click on persico zotero appears directly.
    Error report (i get used to it now ;-)

    1263453182
  • persico is the name I gave to the style, and its id as well
  • (Thanks for the part on "no need to re-add it to zotero")
  • I'm not clear on whether you're still having trouble, but your error report still shows the same error with the _.csl file, so you didn't fix the problem (or didn't restart Zotero/Firefox afterward).
  • edited September 10, 2014
    check if you have a file _.csl in that folder. There likely will be.
  • edited September 10, 2014
    Hi,

    Thank you very much for your help and advice. I have become a much better zotero user now.
    Yet, I finally decided to change the style and use one that is close to my dissertation requirements. I guess persico was too messy ;-)
    Everything seems to run smoothly.
    Yet I have a final issue. In the style I found on zotero repository, which almost fits my requirements (Revue fran├žaise de sociologie-French), conference papers are not specified (neither the conference title, nor the place of the conference). Do you know the csl code that would help me get this info in my bibliography? I tried to look for that on the forums but couldn't find any information.
    Thanks
Sign In or Register to comment.