Problem with file sync download

I sucessfully set up one of my FF profiles to sync my attachments and they all uploaded to the WebDav server without apparent problems.
Now I tried to set up a second FF profile to download the attachments. This has caused a series of problems:
First I got an error message while downloading into the second profile. It said: "Last error: Unexpected status code 200 in Zotero.Sync.Storage.getStorageModificationTime()"
Unfortunately I did not create an error report at that point put restarted FF. After that it seemd ok.
I then went back to my first profile and now encountered problems there. After opening it starts syncing, but then I get the little up/download status bar and after a short while it stops and I get an error message that reads: "Last error: Last known mod time does not match remote time" Restarting FF does not help. The second profile works still fine and I seem to be able to access all attachments there.
Now I did create an error report: 377728843
Advance thanks for any help.
  • ... in the meantime the error message has changed to:
    "Last error: Upload already exists in Zotero.SyncStorage._addRequest"
    ID: 2103912435
  • edited September 8, 2008
    I have just created an entirely new profile (no.3) under firefox and downloaded all zotero-data and attachments. This has caused problems similar to what I have described above:
    It first downloaded the bibliographic information but returned "invalid response from server". After hitting the sync icon again, it started downloading the attachements and produced in the end the same status code 200 message as quoted above. Attachments seem to be in place and accessible

    Error code 768330638

    now the other profile, that was still working in the previous posts (no.2), has the same problems as the very first profile
  • It now gets even messier: I added (under the first profile) an item. Since syncing is seems completely blocked due to the described problems, I then disabled file syncing and restarted FF, so that I can at least sync the database. A conflict resolution windows with 31 pages pops up, I click through them, click finish and get the error message: Reconciliation unimplemented for collections

    error ID: 484352010

    Also I noticed another post with the same problem:

    I would really appreciate some help on this. Is there anything I can do or should I just delete faulty profiles? But then the whole file syncing still doesn't work at all for me.

  • We're still looking into these file sync problems, but, assuming you have all your data and attachments on one side, you probably want to delete zotero.sqlite and 'storage' on the other side and pull everything down again.

    What server are you trying to use for the storage sync?
  • I'm using also mentioned on another thread today as working ok. Uploading everything there worked. Problems started only, when I tried to pull everything down from it to another FF profile.

    I'll try your solution later, but it seems to me like a similar situation as when I created a new profile and pulled everything down there, which, as I said, created some initial problems there, though worked out in the end, but made all other profiles stop working.
  • Dan,

    I tried your strategy and I managed to get Zotero runnning on the very first/my main profile, but I did enounter similar problems as described above. This time I had the debug output running. Let me know if I need to email it to you.
  • You can e-mail the debug output to Thanks.
  • edited September 11, 2008
    I have now Preview 2.1 installed and running on one profile and the trunk on another. Installing the trunk and pulling data and attachments from the servers didn't stop the first profile to work (despite various error messages). The database is synced without problems, but newly added files aren't synced between the two. 2.1. seems to upload them, while it looks like the trunk doesn't. The trunk also doesn't download the actual file uploaded via 2.1 but only the database information on it.
  • Does the second client have file syncing enabled in Zotero preferences?
  • it already downloaded both the database and pre-existing attachments after I installed the trunk. I double checked and those attachments are in place and accessible. Problems affect a newly added item. I also double checked that file syncing is still enabled, it is. And I double checked that the attachment is on the webDAV server
Sign In or Register to comment.