Synced library on 2nd PC: linked files not found (physical files synced by 3rd party/relative paths)


I've installed Zotero Standalone on my work computer. I had a main root folder with PDFs neatly organized in subfolders. I created collections that match this folder hierarchy and have linked (and not attached) these PDFs to their parent items.

It works great : whenever I double click on an item, the corresponding PDF opens in Adobe Reader. Since everything was so great, I set up the base directory path of my main root folder so that Zotero would use relative paths. I then synced my library with Zotero servers.

I installed the standalone on my home computer (I sync all my folders with Allway Sync, so the folders and files are all the same), set up the base directory and synced : all my items are here, so far so good.

However, when I double click on an item, instead of opening the pdf, it says "The attached file could not be found. It may have been moved or deleted outside of Zotero"...

1) The files are not attached but linked (icon of child item is not a pdf but a blank page with a link)
2) I thought it might have something to do with special characters used in the filepath upwards of the main folder (È) so I renamed it, set up the base directory (E) and synced, didn't solve a thing. So I changed it back, but now when I check the attachment path with Zutilo, it keeps showing the old one, and my PDFs still can't be opened...

What did I do wrong, how can I solve this ?
Thanks for your help !

(Sorry for the wall of text by the way...)
  • Can you provide a Debug ID for an attempt to open a linked file?
  • edited June 26, 2014
    Here it is : D1459812099

    EDIT : that one is shorter : D249317314. I think Zotero hadn't finished its startup when I submitted the first one.
    My main folder is /Biblio/ (the one I selected as the base directory on both computers), and the "THÈSE" that appears right before should read "THESE" now, as I modified it in the base directory, but it seems like that change isn't being taken into account...
  • 2) I thought it might have something to do with special characters used in the filepath upwards of the main folder (È) so I renamed it, set up the base directory (E) and synced, didn't solve a thing. So I changed it back, but now when I check the attachment path with Zutilo, it keeps showing the old one, and my PDFs still can't be opened...
    So your Zotero Standalone on the first computer is still functioning properly, correct? If I understand correctly, you were only messing around with file paths on the second computer. When you say "it keeps showing me the old one", you mean the one without the accent?
  • OK, so if you look at the end of that output, you can see the path it's trying to open. Does the file exist there?
  • @aurimas Yes it works fine on the first computer, however it never worked properly on my home computer (as in, I never could open the linked PDFs even though they're properly located), and the same problem occurs on my laptop
  • @Dan the file exists there and I can open it via Windows Explorer/Adobe Reader, but with "THESE" in the filepath and not "THÈSE".
    The base directory contains "THESE", to reflect the change I made on the physical folder name, but is not taken into account, even though when I open the advanced parameters, the base directory shows "THESE".

    However the problem existed before I renamed the folder, when it was identical to the base directory
  • Well, it's not "THESE" — the folder Zotero is looking for is "THÈSE LGBC".
  • But I'm still not entirely understanding what the actual path is and what the actual path is that you're selecting and what the actual path is that appears in the prefs. To eliminate accents as an issue, can you just move the folder somewhere with no accents in the path (there are two, currently) and set that as the base directory to see if that works?
  • Yes, I'm sorry if I'm not being clear.

    The physical folder was named THÈSE before. I couldn't open the PDFs, so I renamed it to THESE, and went to the base directory browser to update the new location. In the advanced panel, it says THESE, but as you can see in the debug report, it's not what it's looking for and I don't know how to change it because it already should be.

    Also, before all this renaming mess, when both physical folder and base directory were correctly named THÈSE, the problem still occurred (which prompted the ensuing mess), so I don't think that it's the cause of the problem, but now this bug is masking the actual cause...
  • That's weird, but note that there's still another accent in the path. Can you eliminate that one too for the moment?
  • (There are definitely some problems with extended characters in paths on Windows, though — we've see this for data directories with usernames containing accents.)
  • Ok I moved the main folder to C:/ and I still have the error : D856714461.

    The physical path of the file is C:\Biblio\Biblio--CARO\FGF1\Sok...pdf

    The path displayed in the advanced settings for base directory is : C:\Biblio
  • So the reason Zotero would still be looking in the previous location (which it is) is because it couldn't find the files at the previous base directory location when you changed the setting. I don't know if that's because of the accents or some steps you took, but you'll need to either move the files back to where it thinks they are (which may or may not work, depending on accent issues) or use something like Zutilo to change the paths en-masse to another location (which also might not work, depending on accent issues).

    It seems there may be a general issue on Windows where it's possible to set a path to a given location with accents but then not be able to access it later. But without trying this out, which I can't do at the moment, that's the best I can tell you.
  • edited June 26, 2014
    Actually, from the looks of it online, almost none of your files are registered as being under a base directory — they have that actual path hard-coded. So this probably isn't working or set up properly on the other computer either.
  • I changed it back to THÈSE (original folder name, with the actual È in Windows Explorer displayed as à in Zotero debug reportsˆ) and it didn't work, but now that I renamed the folder to its displayed name (THÈSE), it's working..!

    So it's definitely an accent issue.

    I'm going to rename all accented folders ; uninstall/reinstall to make a clean install that will erase all previous settings (especially base directory) and then sync the data from the Zotero server
  • No, don't do any sort of clean install. That's not the problem and won't fix anything.
  • edited June 26, 2014
    And this has nothing to do with syncing, either. Here's what you should do:

    1) Find a computer where the linked files all work.

    2) Temporarily disable auto-sync, for good measure.

    3) Set the base directory correctly and make sure the files still work. Then move the directory, make sure the files break, and then set the base directory to the new folder and make sure the files work again. That will let you know that the files are all set as relative to the base directory.

    At that point you can sync, and then set up a base directory on the other computer.

    If you let me know I can look online and confirm that the paths are set up properly relative to a base directory. At this point that's not the case.
  • What you're saying about the files not being registered under a base directory is weird, because the filepaths are not the same between my work and my home PC so if that really was the case I shouldn't be able to open them at all..?

    So how can I modify my folder name and have it taken into account ?
  • edited June 26, 2014
    There are a handful of files under the base directory. The rest have full paths under C:\Users\[...]\Documents\- [...] BiO -\TH[...]SE LGBC\Biblio.
  • Ok, I will try this tomorrow on my work computer and will let you know.

    Thanks for taking the time to look into this !
  • Hi Dan,

    so I followed these 3 steps and everything was just as it was supposed to be (breaking when moved, then working again when base directory updated). I should add that before performing these steps, the base directory was correctly set.

    I did a restore to Zotero server from local data, and I'm hoping that it worked. Is there anyway that I can look myself for the paths online ?
  • I did a restore to Zotero server from local data, and I'm hoping that it worked.
    (Don't use the reset options on a whim. Zotero handles syncing for you, and the reset options are just likely to cause trouble.)
    Is there anyway that I can look myself for the paths online ?
    Not easily, but I can confirm that they're all correct now.
  • Great, thanks Dan !

    Ok, so if I want to make sure that everything that is on my home PC will be overwritten by the data that is now on the server, I shouldn't do a reset from server but just do a basic sync ?
  • "Restore from Zotero Server" would only be necessary if you've been making changes on both sides without syncing and now have conflicting changes (which Zotero would prompt you about when you tried to sync) and you want to choose one side completely. Assuming your home PC was in sync before you went and made the changes on your work PC, there's no need to use the reset options.

    That said, "Restore from Zotero Server" is somewhat safer than "Restore to Zotero Server". You can still run into issues with very large libraries, but it's less likely to cause other issues, so it's probably fine to use in this case if you're unsure.

    In general usage, though, the reset options should definitely be avoided.
  • Thanks for the info !

    So just to be on the safe side and avoid making more of a mess, I decided to uninstall Zotero along with all data and settings, renamed the upstream accented folder (downstream of base directory work fine even if accented it seems) then reinstalled, set the base directory and did a simple sync and now everything works fine on both my home PC and laptop.

    Thank you very much for your help Dan !
  • I'm having a similar problem, I have a large library in Dropbox and use Zotero on two different computers. The relative paths option is really not working very well. Suggestions on how to fix this are most welcome!
  • I'm not clear what "the same problem" refers to here. Are you having problems with accented filepaths specifically, or are relative links just not working for you? They work for tons of people, so we'd need a lot more details of what exactly is happening, what you've tried, etc.
    Also, a debug ID for opening a file as per Dan's first request in above.
  • Hi there, thanks for looking into this. I'm having trouble using the relative paths to linked files.

    The Debug ID is D1842733581

    I have my entire files library on dropbox, and once I use zotero in a different computer it messes it up. Say today I use it on computer 1, tomorrow in computer 2 (where zotero cannot find the files), when I get back to 1 Zotero can no longer find the files. All the files are in this folder:
    C:\Users\Gisele\Dropbox\Apps\ezPDF\Doutorado\00 Bibliografia\Textos [listed as the base directory] (the path in computer 2 might be different, I'd need to check)
    I have tried to revert to absolute paths to see if it worked (it didn't).
    Zotfile and Zutilo are installed.
  • @Dan - could you check the debug.
  • I'm now in the other computer, and can confirm that the relative path here is "C:\Users\gieckerd\Dropbox\Apps\ezPDF\Doutorado\00 Bibliografia". Some linked files are fine, others not.

    Paper Machines, Zotfile and Zutilo are installed.

    The Debug ID is D1686202514.
Sign In or Register to comment.