Zotero 4.0.21 for Mac doesn't work with some non-English locales


After I updated to Zotero doesn't work anymore. It stops at the begining, trying to show the list of items. I tryed Zotero for Firefox, but the same problem. I switched to another user, reinstalled Zotero - the same problem. It seems that my library (2651 items) is not accessible anymore, although I can see it in my custom folder (Documents/ZoteroLibrary).
I'm on Mac, OS X Mavericks.

  • Can you provide a Report ID?
  • [JavaScript Error: "[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsICollation.compareString]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://zotero/content/xpcom/data_access.js :: Zotero.getCollections/< :: line 64" data: no]" {file: "chrome://zotero/content/xpcom/collectionTreeView.js" line: 95}]
    [JavaScript Error: "NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsICollation.compareString]" {file: "chrome://zotero/content/zoteroPane.js" line: 278}]
    [JavaScript Error: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsICollation.compareString]" {file: "chrome://zotero/content/xpcom/search.js" line: 2320}]

    version =>, platform => MacIntel, oscpu => Intel Mac OS X 10.9, locale => en-US, appName => Zotero, appVersion =>, extensions => Zotero Word for Mac Integration (3.5.7.SA., extension), Zotero LibreOffice Integration (3.5.9.SA., extension), SharePoint Browser Plug-in (14.4.3, plugin), Shockwave Flash (, plugin), QuickTime Plug-in 7.7.3 (7.7.3, plugin), Default Browser Helper (537, plugin), Java Applet Plug-in (Java 8, plugin)
  • Report ID: 542538071
  • Hmm, that's very odd. Since that error is happening in three separate places, and only the last one is in new code, it's actually possible that something on your computer has been broken for a while. A few things might not have worked right or been sorted properly in Zotero before, but you wouldn't necessarily have noticed.

    1) Are you running 10.9.3?

    2) Is OS X set to English? If not, does setting it to English help?

    3) If you create a new Firefox profile, are you able to view and create items in a new Zotero library?
  • edited June 25, 2014
    For language, I'm specifically referring to the settings in the Language & Region system preference pane — under "Preferred languages" and "Region". The "Region" setting has broken things for people in a similar way before.

    Try playing with those settings before trying the new Firefox profile.
  • Yes, I switched my OS X (10.9.3) to English (from Romanian) and now it's working!
  • I have same problem after updated to
    MacOS 10.7.5
    Report ID : 361921073
  • edited June 25, 2014
    excuse me,
    I will try to change language setting now.


    I can see my library after switching language settings Japanese to English.
    However, when return to Japanese again, I can't use Zotero.

    I feel happy, if I can use Zotero under my language.
  • Hello,

    I faced the same situation today (Mac OS 10.9.3, Zotero, in Japanese).

    I tried to restart zotero several time, and I found that sometime I can see my library and my items, and sometime I can't.

    Report ID:1708423080

    There was no trouble like this until this zotero version, so I think this is the specific error from current version...
  • edited June 25, 2014
    OK, so this was due to a bug in Firefox 30, not a change in Zotero. (The latest version of Zotero Standalone is based on Firefox 30.) It doesn't seem to affect all locales, just some.

    It's fixed in Firefox Nightly, but we have a workaround. If you're experiencing this (or can reproduce it) in Zotero for Firefox, try installing the 4.0 Beta. To test properly, be sure to restart your computer after changing your language setting back to your desired language, since the setting doesn't seem to fully go into effect until then (even though the user interface changes immediately).

    Assuming this works, we'll put out an update later today with the fix for both Firefox and Standalone.
  • Redirecting from: https://forums.zotero.org/discussion/33792/error-report/#Item_8

    It works great now! I'm keeping my OS in English. However, let me know if you want me to check if the 4.0 Beta works, I'll try it.

    Thank you so much!
  • OK, this is fixed in Firefox, available now for Zotero for Firefox and Zotero for Mac. After updating to that you should be able to change your system back to your desired language. Sorry for the inconvenience.
  • Thank you so much!

    I installed new version (, and it works well in Japanese.
  • I updated my Zotero Standalone to, using "Software Update" menu of Zotero Standalone.
    It works well in Japanese.
    Thank you very much for your quick response.
  • The new version broke Zotero completely: ReportID:115093922
  • ddauer: Disable all your other Firefox extensions and start a new thread with more details if you're still having trouble. The issue above was fixed.
  • edited June 27, 2014
    It looks, though, like there's still an issue with some locales, due to unexpected currency data in the language tag. If anyone is seeing an error similar to "RangeError: invalid language tag: de-CH@currency=EUR", try the 4.0 Beta and see if that fixes the problem.
  • OK, the additional currency-related error is fixed in, available for Zotero for Firefox now and Zotero Standalone shortly. If you're running the beta version, you can install from the download page.
  • I am using zotero standalone 4.0.23 or simply using firefox on Max ox yosemite. And I installed Mac word from Office 365. I can see that the zotero citation tools are there, but no response when clicked.
  • start a new thread, please. This one is not about the Word add-on and the problem described has been solved.
  • Thank you. Please direct me to where the solution is please.
  • no, it's the issue in this thread that's been solved, not yours. That's why we need you to start a new thread, dedicated to your issue. ("Start a New Discussion" at the top left of this page).
Sign In or Register to comment.