Zotero erasing my notes - error report id 528462677


I'm using Zotero version on Firefox on Mac and am having a similar problem. Often the text in my zotero notes (standalone sticky notes) are being erased.

The note and tags are still there when I returned, only there's no text in them. Also, if it doesn't happen to a note after the first day or two, then that note tends to be fine.

Sometimes it happens after I add a tag to the note, other times it's when I close zotero in firefox (command + shift + z) and reopen it.

There's no indication that anything happened, but the sticky note is empty of text. I checked in zotero.org, and they're blank there too.

I'm typing correctly, and making sure the text is there, (clicking on another entry in my library and going back to the note, etc.), before closing. I've done several tests, and it basically happens spontaneously only some of the time.

This wasn't a problem until about one month ago, and all my old notes are still there with text, but it's annoying as I just lost a lot of text in a note. In the meantime I'm using word docs and uploading them separately to zotero, but I have many short notes so it's not the best solution.

I tried disabling all add-ons but it still happens. Thanks for any help you could give.

  • That's very odd, but just to check something, can you try turning off file syncing in the Sync pane of the Zotero preferences to see if that makes a difference? You're at your file sync quota, so file syncing won't actually work anyway, and it's possible there's some bug here related to the failed attempts. (I maybe recall something like this, but I don't think we've reproduced it.)
  • Thanks for your quick response. I turned it off and luckily so far everything is working.

    For a month or two before this happened, I was having trouble syncing--the sync ran continuously and just wouldn't resolve--so maybe it was related to that.

    In any case, sync is working well now, and I can't reproduce the note problem.

    I also deleted a lot of the PDFs so I'm below the quota. Don't know why I didn't do that sooner.

    Thanks. I'll comment again if it comes back.
  • edited May 31, 2014
    OK. To clarify, if you're below the quota you can turn file syncing back on. (Note that you'll need to empty the trash after deleting the attachments for them to stop counting against your quota.) This seems to be a bug that occurs when you're at your quota and file syncing is enabled.
  • Error report: 1203125882

    Ugh, it started again. This time, I typed the (short) note on my laptop and it disappeared, so I retyped it.

    Then I could see the text when I clicked on the note, but the first line of text wasn't coming up in the title bar in the list of sources. Still--the text was there in the body of the note.

    Now I came to my work computer, and after syncing, the note is there, but it's blank. The tags and related items are there, but there is no text in the body of the note, nor in the title bar. It's also an empty note on zotero.org.

    I'll check my laptop when I get home. I've also created a new 'test' note here (which is fine), and will check if it syncs with my laptop.

    Sycning is working well, not near the quota, etc. It had been working fine until now. Not sure what changed.

    I often can't reproduce this when I try, but then randomly it happens when I actually want to make a note for research.

  • edited June 17, 2014
    It does appear to be related to sync.

    When I went home last night, zotero had bumped me out of sync, and it prompted me to put in my password (which hasn't changed), then synced normally. Same thing at work this morning. Don't know if it was reset somehow.

    Syncing fine now, no more repeats of the note issue yet.
  • edited June 18, 2014
    error report: 962877606

    It's happening again. Only on home laptop (mac).

    I write the note, it's there in the note pane, but if I look at the same note on zotero.org, it's blank. Sync appears to be completing fine.

    Please do let me know if there's anything I can do. I'm losing research notes because it's such a habit to paste them into zotero instead of word, though of course I'm also developing workarounds.

  • Can you disable your other Firefox extensions and then provide a Debug ID for attempting to edit the note in question (assuming this still occurs after restarting Firefox)?
  • edited June 19, 2014
    Also, it's still a bug if this is happening, but you appear to be at your file sync quota again. You should either delete files and empty the trash or disable file syncing.
  • Ok, I'll try that. It's happened before without add-ons enabled, but it's hard to catch, and I can't really work on my laptop without the add-ons (wiredmarker, scrabook, privacy stuff largely just as a precaution, etc.). It seems to only happen when I don't want it to.

    I don't know if there's a way to tell when I'm approaching the quota--don't see it in preferences. It's strange that I'm already back at the limit. When this last came up, I deleted several hundred (300-400) Plarge DFs and haven't put them back. I've added entries in the meantime, but no attachments.

    I saw that "sync full text" was still checked, so I turned it off and emptied the trash. (Thought it was already off.)

    Thanks. I'll let you know once I have an error ID.
  • Last thing: today and yesterday I've been getting "can't access dead object" when syncing. It goes away if I just hit the button again.

    Error report (add-ons enabled): 1761268866

    Also, if anyone else has this problem, the fastest workaround I've found is to just add notes directly into my library on the website, zotero.org, rather than in my library.
  • edited June 19, 2014
    I don't know if there's a way to tell when I'm approaching the quota
    Approaching doesn't really matter. You get a sync error when you hit it that tells you what the problem is. But you can see your current usage from the storage settings page.
    When this last came up, I deleted several hundred (300-400) Plarge DFs and haven't put them back.
    Did you empty the Zotero trash?
    I saw that "sync full text" was still checked, so I turned it off and emptied the trash.
    Syncing full-text content doesn't affect your storage quota. If you want to make full-text content searchable on all computers and zotero.org, you should turn that back on.

    And I'd really need a Debug ID, not a Report ID. If it has to be with other extensions enabled, so be it, but you'd need to clear the output immediately before reproducing the problem (so, for example, before starting to write a note). You can leave the preferences window open and hit Clear Output before you start typing in a note, and submit immediately after reproducing.
  • edited June 26, 2014
    Debug ID: D121655586.

    Thank you. All of the info you gave is very helpful. For now, I'm going to switch to Chrome + Zotero standalone to see if I can just avoid the problem.

    The debug ID above is with all add-ons disabled. I just created a note and tagged it, but the error didn't occur. As I mentioned before, it's not really possible to duplicate it on demand, but it still happens once every week or two.

    It seems there are bigger problems with my Firefox, though, so maybe the error originates outside of Zotero.

    After disabling all of my add-ons and most of my extensions, Firefox became unusable (extremely slow, crashing consistently, etc.) and their troubleshooting info (resetting it, creating a new places db, etc.) hasn't helped so far. So I'll do a clean install. In the meamtime, chrome + zotero standalone seems to work.

    Thanks again.
  • edited June 26, 2014
    Did you try simply disabling file syncing? It sounds like all of these issues may be as simple as repeated failed file syncs because you're at your quota (not that that should cause the note issue).
  • (And don't do a clean install of Firefox unless you've also tried disabling Zotero and the problem persists.)
  • I'll try that, thanks. May have to spring for some extra space and see if that does the trick. So far standalone is working well.
Sign In or Register to comment.