[solved] Error report 1861502808

Zotero (Firefox plugin) was hidden, and I clicked on the Save to Zotero icon in the URL bar (http://www.ncbi.nlm.nih.gov/pmc/articles/PMC1378885/), but it failed translating the metadata.

I thought it happened because I didn't use Zotero previously in that Firefox session, so I pressed Control + Shift + Z to show Zotero. I received an error message saying there had been an error launching Zotero. Clickling in the Report menu entry, I got number 1861502808.

I'll try to restart Firefox and see what happens.
  • Same error message:

    [Exception... "Component returned failure code: 0x80520010 (NS_ERROR_FILE_NO_DEVICE_SPACE) [mozIStorageConnection.executeSimpleSQL]" nsresult: "0x80520010 (NS_ERROR_FILE_NO_DEVICE_SPACE)" location: "JS frame :: chrome://zotero/content/xpcom/db.js :: Zotero.DBConnection.prototype.query :: line 149" data: no] [QUERY: INSERT INTO itemTypesCombined SELECT itemTypeID, typeName, display, 0 AS custom FROM itemTypes UNION SELECT customItemTypeID + 10000 AS itemTypeID, typeName, display, 1 AS custom FROM customItemTypes] [ERROR: database or disk is full]

    The disk partition is 21% free.
  • then there's another reason that mozilla is returning a disk full error - possibly a permission error (though that should look differently) or security software, or you're looking at the wrong partition (possibly you have the data directory and the Zotero directory on different partitions.)
  • Thanks for helping, adamsmith.

    I have checked the file permissions from $HOME to $HOME/.mozilla/firefox/[profilename]/extensions/zotero@chnm.gmu.edu.xpi. The correct username and groupname are still there for every file, and I've got read and write permissions and, usually, execute permission (but not for zotero's xpi). I didn't change any permissions, at least not manually.

    But then, dropbox started failing on a permission error at the same time... The most noticeable thing I did before was updating GNOME to 3.12.2. I can't think of any package that could interfere with Zotero; Firefox and SQLite, for instance, weren't updated now. (Using 29.0.1 and, by the way.) Rolling back to nautilus (the file manager) for dropbox's sake didn't make a difference, either for dropbox, either for zotero.

    I do have clamav installed, to spot viruses in Dropbox (most of my colleagues use Windows), but clamav's log file didn't report anything but loading the daemon and updating definitions. I couldn't find any report of clamav stopping zotero or dropbox from working, but I'd be willing to try turning it off if you thing it may be the issue.

    None of my partitions are full, and I haven't moved things around of late.

    Could there be any limit to database files in Firefox? I didn't change any config of late, and I can't find anything about such limit.
  • edited May 24, 2014
    Could there be any limit to database files in Firefox?
    I don't think there are limits, not. We've had someone with a database with 700,000 items (sic) and while that was impracticable for other reasons, it still worked in general.
    App armor could be interfering, maybe?

    edit: you're also checking the wrong directory for permissions. First place to look would be the zotero data folder, which is right under ./zotero from the Firefox profile
  • edited May 24, 2014
    Oh, and I have all permissions for $HOME/.zotero as well.

    Edit: that's because I once had a Standalone installation. Moving the folder to inside the profile and updating about:config/extensions.zotero.dataDir didn't make any difference.
  • My database is under 700 entries :)

    I don't have AppArmor installed, or SELinux.
  • What distro?

    Have you tried disabling your other Firefox extensions?
  • Hi, Dan Stillman.

    I use Arch Linux.

    Just tried disabling all other Firefox extensions, but I still get the same error.
  • Right, that's what I figured. A bunch of people have reported this error on Arch Linux, and it's unlikely we can do anything about it. For what it's worth, some of those reported just turned out to be other full partitions (e.g., / was full, but not /home) — I know you say that none of yours are full but it might be worth double-checking that (including, say, tmp space).
  • Dan,

    My root partition was actually full. I happened to overlook it because it was very distant (in the output of "df -h") from my home partition, and I never thought it could make any difference.

    Arch Linux updates packages a lot, much more like Debian testing or sid then Debian stable, so the the package cache does get full from time to time.

    Thank you very much for the assistance!
  • When Zotero stopped working, I couldn't find anything relating Arch Linux to the issue. So I inserted this forum post to help other people: https://bbs.archlinux.org/viewtopic.php?pid=1419707
Sign In or Register to comment.