Ordering dates in citation of same author. What should be changed in a CSL style?


In the style ABNT-UFMG-FACE


the citation of same author and different dates is as following:
(AUTHOR, 2008, 2010, 2003)

Considering the change in the dates ordering to arrange them chronologically (AUTHOR, 2003, 2008, 2010), what should be changed in this style?

  • It works okay for me here. Is the "Keep references sorted" box ticked in the word processor plugin popup?
  • It doesn't seem to be connected to the word processor plugin popup (I tried that).

    On the other hand, when I change styles, the order changes, so it seems a CSL code issue. Any idea?

    I made available in the following link a RDF sample of the case I am referring to:


    Thanks for helping!
  • works correctly here, too—(SILVA, 2003, 2008, 2010)—, and the CSL code looks right. If you switch back to the ABNT style do the citations go out of order again?
  • edited May 21, 2014
    Actually, the problem remains, but I pointed out above the wrong ABNT style. Sorry!

    The one I am using is this (which is a variation of the same Style):


    Since the former ABNT style is correct indeed, could you please say what could be the problem in the CSL code regarding the order issue in this latter style?

    Thanks for helping!
  • don't see any problem with that style either and that, too, works for me. Have you tried in a new document with those three cites? (insert them in random order to make sure).
  • edited May 21, 2014
    Very strange. Despite the inserting order the citation output is always the same (SILVA, 2008, 2010, 2003). If I change the style to the other ABNT everything works great = (SILVA, 2003, 2008, 2010).

    I also turn off the computer, created new docs and so on.

    I would appreciate a last help from you testing an ABNT CSL file I made available in same shared link:


    It is beta and its content will support a major update for both ABNT styles mentioned above.

    This beta version is presenting same date ordering problem for me. How does it work for you?

    Thanks for that!
  • works for me - did you try in the Zotero test pane? Does it look right there?
  • (btw. - please share styles on gist.github.com, where I can see and copy them without downloading)
  • Total nonsense!

    I just checked the style through validator and tested in the pane. Problem remains... Take a look in a screenshot from the pane:


    Is there any way I could erase all ABNT style leftovers into Zotero. I already deleted the style through preferences=> cite=> styles, reinstalled it and problem remains...

  • edited May 21, 2014
    @cadudesun: Check the form of the authors in the bibliography, with the "initials" version.

    The style is using the "author" macro as sort key in citations, but printing with the "author-short" macro. The bibliography uses the same "author" macro as the citation sort key, so it shows what the sort keys actually look like to the processor.

    To fix the sort, you just need to change the first citation sort key from "author" to "author-short". But you probably also want to check the name format applied to newspaper articles in the "author" macro -- it may need to be changed to use initials, like the rest of the style.
  • I doubt this is because of something cached. Could you confirm your Zotero version? I tried with both the beta and the most recent standalone, so this shouldn't matter, but let's make sure.
  • ah yes - what Frank says. I'm a little puzzled this doesn't affect sorting on my machine - I tried with your items - but I'm pretty sure he's right that this is the cause of the issue - note how the same author appears differently in the bibliography.
Sign In or Register to comment.