Standalone not working

I recently changed my username on my iMac, and the standalone Zotero app stopped working. My library doesn't show up, it won't sync (pushing the sync button does nothing - no spinning icon, nothing else happens), and it won't restore from the server. My library appears fine on the server and in the Firefox extension, and it seems like I can use the Word extension just fine (I haven't tested it extensively, but I was able to insert a citation and generate a bibliography a few minutes ago).

I prefer the standalone app, and so would like to get it working again, but I'm not sure what to do. I tried reinstalling the app, but it didn't help.

Thanks in advance for any help with this.
  • can you provide an error report ID from Standalone?
    if it won't let you submit the error report, just copy&paste the content of the reporting error window here.
  • In the standalone app, there's no 'Error Report' menu item in the Action menu. The menu items in the Action menu are Import, Import from Clipboard, Export Library, RTF Scan, Create Timeline, Preferences, Support and Documentation, and About Zotero.

    There is an 'Error Report' item in Firefox, and if I choose that, it says:

    The following errors have occurred since starting Firefox:

    Could not read chrome manifest 'file:///Applications/'.
  • When I follow the guidelines there, I get:

    Could not read chrome manifest 'file:///Applications/'.

    While creating services from category 'profile-after-change', could not create service for entry 'Disk Space Watcher Service', contract ID ';1'

    Timestamp: 4/29/14, 8:05:25 AM
    Error: NS_ERROR_NOT_AVAILABLE: Cannot call openModalWindow on a hidden window
    Source File: resource://gre/components/nsPrompter.js
    Line: 382
  • Can you try to generate real-time debug output for Standalone startup and email it to with a link to this thread?
  • Following those instruction didn't produce any output. It just opened Zotero, where the same nothing continued to happen.
  • Make sure you're running the latest version of Standalone (currently 4.0.20) and try again. It shouldn't be possible for the Standalone window to open without there being debug output.
  • I installed 4.0.20 and ran the code from the real-time debug output (twice), and it still produced nothing.

    I previously had 4.0.19 installed, so I put that app in the trash. When I installed 4.0.20, it already had my username and password in the sync settings.

    Is there something other than simply deleting the app that I can (or should) do to be able to cleanly install the newest version? I have it installed as a Firefox extension, too, for example. Would getting rid of that prior to installing the standalone do anything useful?
  • Oops, sorry, the command line on that page was incorrect. Try what's there now.
  • Got it. I sent the email. Thanks for all your help with this.
  • OK, disregard my previous message about Select All — we can reproduce this when the Zotero data directory is missing. We're working on a fix for the proper error message not appearing, which it's supposed to, but you'll need to figure out where your data directory is and point Zotero there from the Advanced -> Files and Folders pane of the preferences, which you should still be able to access via the gear menu in the Zotero toolbar.
  • If you're not sure, and you're using syncing, it's probably also a good idea to disable auto-sync from the Sync pane of the preferences before changing the data directory setting.
  • That did it! Thanks so much for guiding me through this.
  • I had the same problem - no syncing, no adding new libraries or entries, no nothing.
    After reading this post I checked the data folder in settings, and it showed some folder which was no longer on my computer. Seems like it was an old entry from my previous laptop.
    However, I could not change the setting to default Firefox profile folder unless I closed the standalone app, then restarted it, and - when the window popped up asking me would I like to import previous libraries and data - select "No" insted of "Yes". The standalone app then seems to have created a new data folder, and everything is working from then on.
  • if you still have Zotero for Firefox installed, you should make sure it shares the data directory with Standalone. See here for details:
  • Thanks very much for your hint, adamsmith.

    I checked, and there were indeed two different directories, one for the Standalone and one for Zotero for Firefox, one at
    and one at

    Following the instructions you kindly provided, I tried to point Zotero for Firefox to the Standalone data directory. However, after restarting Firefox, Zotero told me that it could not locate the folder, and would I like to relocate it.
    I clicked yes, and the folder was there all right.
    However, to make sure, I used copy-paste from the Windows Explorer to make sure the path was correct.
    Zotero then said – again – that it needed to restart, I restarted, and the same thing happened again. Even though the path was correct, and the zotero.sqlite file is there as well.

    I then tried deleting the Zotero for Firefox profile folder, and point Zotero for Firefox to the Standalone data directory again, but essentially, the result was the same. On startup, I was asked that as I seemed to be using Zotero for Firefox for the first time, would I like to import all settings from Standalone, I clicked Yes, restarted, started Zotero for Firefox, and received the previous message that the data directory could not be located. (Again, even though the path was correct.)

    As I was going in circles, I tried it the other way, pointing Standalone to the Firefox data directory. This resulted in the original problem, i.e. Standalone not doing anything.

    So I changed all data directory settings back to default, which for some reason means separate directories, but at least both Standalone and Zotero for Firefox are working and syncing.

    However, as really I'd prefer for the directory to be shared, is there any way this can be fixed? E. g. By uninstalling both the add-on and the Standalone, deleting the directory folders, and re-installing everything? But what would happen to my data then?

    (I'm using Zotero in German, so I hope I got all the terms right in English.)
  • The problem may have been the Umlaut in my user folder name. I've spent the afternoon trying to alter this, and seem to finally have succeeded. (Windows 8.1 does not allow you to simply re-name the user folder name, one has to change the registry, too.)

    After un- and re-installing Zotero Standalone, it now shares the Zotero for Firefox data directory. Heureka.
Sign In or Register to comment.