Bookmarklet broken? Getting stuck at the log-in stage when adding to Z4 standalone

I've been using an iPad 2 and the Zotero bookmarklet for a year at least, without trouble—love the bookmarklet—but for the past couple of weeks it's not been working.

On a page whose translators worked great before (let's say Google Scholar, but the problem happens with JSTOR and my library catalog and others), I now get stuck. I click the bookmarklet, get asked to log in (over and over—it doesn't seem to retain the authorization anymore), log in, and there's where it stalls. The log-in pop-up window turns into a gray window saying "authorization complete," and behind this in the corner I see the "Saving Item ..." screen, but nothing happens, and I'm forced to leave the page. None of the "saves" that have gotten to this point have ever shown up in Zotero standalone. Adding things via Safari plug-in on my laptop still works fine; it's just the bookmarklet that's asking to log in repeatedly and never responding when I do.

What broke?

I did uninstall and re-install both Zotero standalone 4.0 and the bookmarklet (well, deleted and recreated that) to no avail. I also installed iOS 7 recently, and haven't noticed any other strange happenings, but could it be incompatibility between the now-hardly-new OS and the bookmarklet?

The Zotero bookmarklet was such a happiness, I'd hate to think it's lost to me! Any help is appreciated.
  • ... "Saving Item" [notice in the corner of the] screen, sorry.
  • the bookmarklet per-se is definitely not broken. Don't have iOS7 here so I can't test that, but I'd be pretty sure we'd know about that, too.

    Maybe try with a different browser (say Firefox mobile) for testing?
  • You might also try force-quitting Safari by opening the app switcher (by double-pressing the home button) and swiping Safari upward to close it.
  • Still have this problem.

    Thanks for the suggestions. Firefox Mobile is for Android, not iPad, unless I'm mistaken. I tried Chrome for iPad and Diigo, but the bookmarklet doesn't work in either one; I added it to bookmarks and edited the URL, but neither browser knows what to do when I click it. A blank page opens up.

    Forcing Safar to quit does quit Safari, of course, and when I open it up the citation I was trying to save is gone and I have to start over, with the same results.

    Today's attempt to save a Google Book entry via the bookmarklet in Safari did the same as usual: makes me log in, gives me the "authorization complete" grey pop-up box, and freezes.

    What's bothering me is this used to work perfectly for so long, and now it doesn't. So I don't think a Safari is the issue, nor is how I'm up using the bookmarklet, unless Safari in iOS 7 does something new.

    Any ideas?
  • Something else to mention: Zotero never seems to recognize that I've logged on very recently and clicked the "remember me" button. I have the feeling that if only the need for me to sign in didn't interrupt the translation/save process every single time I click the bookmarklet, it would work fine. Is there a way I can get Zotero to remember me, other than the "remember me" button?
  • so the necessity to login every time - is that just the case when you use the bookmarklet, or also when you return to normally, i.e. just browsing?
    If the latter, it's worth looking at your cookie settings.
  • Hmmm. It's the latter, so I'll definitely look into the cookie settings. Thanks!
  • try setting this to "never"
    for testing.
  • Thanks, yes, I did that. Now the browsing isn't an issue anymore (i.e., "remembers" me), but even though I'm still logged into (in another tab), when I click the bookmarklet I still have to log in and get frozen.

    One baby step closer, I hope, but still puzzled.
  • edited March 15, 2014

    One new thing noticed: when the bookmarklet prompted me to log in this time, instead of entering my info I clicked "Login" in the top right of the prompt/box, i.e., the link to log into This popped up the Zotero page and the same prompt/box, but my userid and password there were auto-filled, which never is the case when the same window prompt pops up in response to the bookmarklet. (So Safari seems, at least since I changed that cookies setting, to remember my login info when I'm on but not w/ the bookmarklet specifically.)

    However, when in the prompt/box I clicked the red "login to Zotero" button, I got the same problem the bookmarklet gives me: a grey (full-page now) screen saying "authorization complete" beyond which I can't click or go anywhere. Frozen again.

    Does any of this help? Thanks for looking into this with me.
  • edited October 29, 2014
    Disregard that. I turned off cookie-blocking for all sites, and now it seems to work.


    Hi again,

    Just got a new iPad mini, and I'm having this problem all over again. Zotero standalone 4.0, bookmarklet, and Safari. The bookmarklet triggers the window where I select which articles I want from a list (in Google Scholar), but once I select one, I have to log in, and Zotero never remembers me. Logging in gets me a gray screen that says "Authorization complete," but nothing happens after that; it freezes. I have to close Safari, and the item hasn't been added to Zotero when I return.
  • I’m having this same problem, even though it worked earlier today. My cookies are turned off. This is in safari. I’ll try in Chrome.
  • 1. Settings — Safari — Prevent Cross-Site Tracking — Off

    2. Settings — Safari — Clear History and Website Data

    3. Safari — — login

    4. Your safari Zotero bookmartlet should work now.
Sign In or Register to comment.