[SOLVED] report ID 827738277 : refresh zotero failed in windows. document made in ubuntu linux


I have problem with refresh zotero.

The problem if I open doc in ms office in windows xp. The document it self, made in ubuntu with libreoffice.

The link was not broken, I still able to click edit, but when I enter same problem with clicking refresh zotero

the message:
Zotero experienced error updating your document.
A field code in this document is corrupted

but when I open it again in libreoffice in ubuntu, it is still work flawlessly.

why do I need this ?
since my co author is using windows only, and I am using ubuntu.

in Ubuntu 13.04
Libreoffice 4
Zotero add-on

in Windows Xp
MS Office 2003
Zotero stand alone 4.0.11

Citation style : National Library of Medicine
with little modification to match with Teaching and LEarning in Medicine.
Format using Bookmark.

I dont know what is the problem with the setting. Do you have any suggestion ?
  • first thing would be to updated Zotero on Windows. We can't help troubleshoot outdated versions.
  • oo ? is that outdated ?
    oppss .. ok. will do that
  • versions for the FF add-on and Standalone are parallel, i.e. the current Standalone version is 4.0.17
  • updated already, to 4.0.17
    problem still occurred
  • provide an error report ID after triggering the error in Word
  • this is the report ID

  • @Dan - anything in there?
  • string(273) "[JavaScript Error: "Error loading style '_.csl': undefined" {file: "E:\zotero\styles\_.csl" line: 0}]

    [JavaScript Error: "A field code in this document is corrupted."]
  • it looks like the style may not be installed on the Windows computer or at least something in the styles is corrupted.
    If you're sure you have in fact installed your custom style (which must have the same id on both computers), try resetting the style in the advanced tab of the Zotero preferences on the Windows computer. You will then have to re-install the style. Do that and try again.

    Alternatively try to switch the document to a different style - one of the pre-installed styles, e.g. - for testing purposes. I'd expect that to work.
  • The style has an invalid ID, most likely.
  • OK, so given that Dan thinks this is likely a problem in the style, try switching to a different style as the first step. If that fixes it we can take a look at your custom style.
  • edited March 8, 2014
    i found the styles I use in ubuntu, and copy the styles onto zotero standalone in windows.

    install it ... succeed.

    sadly, the problem still exist ...
  • test with vancouver style ..
    both in ubuntu and windows has it.

    problem still exist ...
  • Did you first reset your styles from the Advanced -> Files and Folders pane of the Zotero preferences, as adamsmith said? You need to reset your styles, restart Zotero, and test it, before installing any custom styles.
  • edited March 8, 2014
    miss that reset things.

    I did try that too, reset.
    and still doesnt work.

    FYI, I tried with 2 style.
    my custom style and vancouver.
    And vancouver is available in zotero when we install for the first time.
  • OK — then we'll need another Report ID that shows this error after resetting styles and before reinstalling a custom style.
  • edited March 8, 2014
    Oh, and also after reselecting a style in the document from the plugin's document preferences window.

    So, in other words, restart Zotero, reset styles, go back to the document and change it to use one of the existing styles, and then try to reproduce the error.
  • I restart zotero, reset style, go back to document ...

    and this is the report ID 485417086

    I was using vancouver at this time, not using my custom style.
  • A field code in this document is corrupted.
    OK, that's a different error (though likely caused by the other problem).

    See Debugging Broken Documents.
  • that was happened if I click zotero set doc preference

    report ID 86304991
    this if I did click edit citation, and hit enter.

    both problems were mentioned in my first posting
  • edited March 8, 2014
    Right, but it's the first error that matters, and before you were getting a different error first. Now you should try following the steps I linked to (still without reinstalling a custom style).
  • Solved,

    go through until step 9.
    finally found 1 problematic paragraph. deleted it. replace.
    and the problem gone.

Sign In or Register to comment.