Report ID 995369507

My library is synchronized via webDAV, to a server at my university, originally set up by copying the cert_override file from firefox. This worked flawlessly for about six months at least. I sync both my work computer (linux) and my laptop (linux/windows dual boot, library location on a shared partition). Recently I got a sync error on the laptop, checked the "verify server" button in the sync preferences, and got an SSL error. It happened first under Windows on my laptop, but I shortly thereafter switched to Linux and got the same error. I was able to get it working again by recreating the cert_override file and replacing the old one with the new one. I had to do this on all three zotero instances. Each time I did it, something close to every PDF in my library had to be freshly uploaded or downloaded. Then everything worked fine for about a week, and now I'm hitting the same problem again. The only cause I can think of is that Firefox updates are breaking this? I don't recall doing any Zotero updates in the last few weeks, but I do recall a firefox update.
  • Sorry, I'm not clear on this — are you saying that the cert error is happening repeatedly, or the reuploading? (It's not actually reuploading. Zotero never uploads files that already exist, but in some cases it has to check all files to see if they've been changed.)
  • Sorry. when I said "hitting the same problem again" I meant that the cert error has happened again, 1-2 weeks after I had re-generated the cert_override on all three zotero instances.
  • edited February 26, 2014
    The expiration date on that self-signed cert is February 17, 2018, so I'm guessing it was just recreated on February 17 and perhaps another time before or after for some reason. Did you just have to copy cert_override.txt over again, or did you have to re-whitelist the certificate in Firefox. If the latter, then the cert just changed and this has nothing to do with Zotero.
  • I did have to re-whitelist. Which is odd because none of the other members of my lab (who also use Zotero and sync attachments to that server via webDAV) had this problem. I'll assume for the moment that this is not a Zotero issue, and see what else I can find out... oddly, the certificate manager in Firefox shows an issue date of 03/19/2013 and an expiry of 03/19/2014. If/when I get to the bottom of this I will post further details here.
  • You're looking at the previous saved certificate in Firefox, but that's not relevant — the way you check the valid certificate for a domain is by clicking on the padlock after loading the site. The current certificate for the domain in your report shows February 18, 2014 – February 17, 2018. So this absolutely would've broken on February 18th.

    In any case, if you had to re-whitelist in Firefox this is in no way related to Zotero.
  • (As for why the other people in your lab didn't have to do this, I couldn't tell you. Maybe they're connecting via HTTP?)
Sign In or Register to comment.