Zotero Libreoffice integration stops working after upgrading to Mac OS X 10.9 Maverick

I just upgraded my 2012 MacBook Pro 15'' Retina to OS X 10.9 Maverick. After upgrading, the Zotero integration in LibreOffice (v. stopped working. I am using Zotero Standalone. The integration with Microsoft Word continues to work fine.

I checked the troubleshooting page (https://www.zotero.org/support/word_processor_plugin_troubleshooting) and note that in my LibreOffice preferences "“Use a Java runtime environment” IS checked, but there is no JRE listed. However, the java site (https://java.com/en/download/installed.jsp) shows I have the recommended version installed (Version 7 Update 51). So now I'm not sure if this is a LibreOffice bug or Zotero. Any hints would be appreciated!

(Note: A funny thing is that in my Zotero Standalone preferences, it also says that I do not have the Microsoft Word add-in installed. However, as I said, Zotero in Word is working fine...)

I realized that there was a newer version of LO out (4.2). Updating LO took care of the JRE issue. Then I reinstalled Zotero, after which Zotero claims that my LO plugin is installed. However, still not working. Trying a manual reinstall leads to the following error alertbox from LibreOffice Extension Manager: "(com.sun.star.lang.DisposedException) { { { Message = "Binary URP bridge disposed during call", Context = (com.sun.star.uno.XInterface) @1165ce1b0 } } }". Manually removing the extension in LO and trying to reinstall results in the samme error.
  • Simon would ideally look at this, but could you specify how this isn't working? Do you get an error message, are the toolbar buttons unresponsive, or do you not get a toolbar at all?
    Have you tried re-installing the LO plugin from the "Cite" tab of the Zotero preferences.
  • If you get an error from a manual install, it's a good sign that Java is still not working properly. You could try moving the LibreOffice profile directory to the desktop and see if that helps. Alternatively, you can try installing Java 6 from Apple, although Oracle Java 7 really ought to work.
Sign In or Register to comment.