Unable to locate files on a new Macbook for syncing with WebDAV

I have just installed a new harddrive to my Macbook (late 2009 model). In the old harddrive, I was using the most recent version of Zotero and the Zotfile plugin (3.1). I synced my .pdf attachments via Zotfile but saved them thru WebDAV on Box.com. Now that I have installed the new harddrive and have the latest version of Zotero and Zotfile, and synced my library from the Zotero server, and synced my Box.com account, I am unable to locate the .pdf files via the Zotero standalone app as I did previously.

I have gone into the sync settings in preference and verified the Box.com account--it says everything checked out OK on that. But when I select an item from the Zotero standalone library, right-click to "Show File," an error returns with "File Note Found. The attached file could not be found. It may have been moved or deleted outside of Zotero." However, I'm looking at my Box.com sync folder and the files are still there with the appropriate filenames that Zotfile added when they were originally attached.

When given the option to manually locate the files, I have done so and it appears to re-establish the link. But there must be some other way of handling this instead of going one-by-one on each file, right?

In hopes of expediting the process, I generated a DebugID: D1117127182.
  • What exactly are you having Zotfile do? It can't "sync".
  • Doesn't zotfile handle/manage attachment additions and other attachment functions? this is what I meant. If I am wrong, then oops!
  • well it handles renaming and potentially moving attachments. If you're using it to move attachments, then Zotero doesn't control their sync anymore and I'm not sure what the WebDAV is doing. So what exactly do you have ZotFile set up to do?
  • i use it to rename attachments, extract annotations, and sometimes send materials to devices.

    when i attach files, i chose the "attach stored copy of file" option and the location i choose to store the .pdfs is in the box.com sync folder. like i said, previously this was not a problem, and it wasn't even a problem when i backed up from a timemachine backup--all the files were in the correct locations and the links between the items in zotero and the corresponding .pdf files were perfect. but when i installed this new harddrive, i did not use the timemachine backup. instead, i did a clean install. then i installed zotero. then i installed box.com. then i connected the two with the same settings as before. (i intend to use migration assistant and carry over other files later.) for some reason, zotero will not recognize that the files are present in the box.net sync folder.

    i can manually re-establish the links between the two. i have done this for three files already, quit the applications, restarted, and the links remain. but to do this for 600+ items isn't really practicable.
  • So you have the data directory location (under advanced --> Files and Folders) set to a folder in box.com?
  • I have the data directory in Macintosh HD->User->Library->Application Support->Zotero->Profiles->86eacyn...

    I tried re-attaching files on the old computer, and I think I was wrong in my earlier post--I haven't been "attach stored copy of file..." but "attach link to file..." aside from that, the attached (linked) files were in the box.com folder, in the same place with the same directory on the new harddrive. i suppose there's no way around having to re-link all the items manually.
  • edited January 21, 2014
    I tried re-attaching files on the old computer, and I think I was wrong in my earlier post--I haven't been "attach stored copy of file..." but "attach link to file..."
    Ah OK, that's an important difference.

    You may be able to use Zutilo to change all links at once. I doubt you'd have to do that manually in Zotero.

    I'm pretty sure something about the filepath to your box.com folder has changed - Zotero just stores the full filepath - if anything changes the links break (but Zutilo would help you to fix that).
  • chairman of the dismal science indeed! your advice worked perfectly--zutilo is the way to go. many thanks for helping me solve this.
  • lcyarrington -- i'm currently in your shoes. are you able to describe how you used zutilo to get your fix? thanks
  • edited July 31, 2017
    Zutilo has a command to modify attachment paths, documented here: https://github.com/willsALMANJ/Zutilo/blob/master/docs/COMMANDS.md#item-menu-functions

    Installation instructions: https://github.com/willsALMANJ/Zutilo#installation
Sign In or Register to comment.