Strange behaviour after "New Item" -> [anything]

After using Zotero for a while (~1 hour), I used the "New Item" toolbar menu to select (for the first time ever) "More" -> "Report". A new item was created and selected, and showed the Report icon; but the rightmost user interface pane contained all the details for a different item, a Journal Article (that I had created in a previous Zotero session). By way of testing, I created several other items of various types via the "New Item" toolbar menu, and had the same result (including the details of the same Journal Article item in the rightmost pane) each time.

I did no further testing before closing and re-opening Firefox, after which the problem was solved, and the new items I'd created were all present but now had all blank fields as originally expected.

I've been unable to replicate this bug.
  • Unfortunately things like this are pretty much impossible to diagnose without either steps to reproduce or an error message. The latter would require turning on javascript.options.showInConsole in about:config and keeping it on until the problem happens again. (See the Advanced Instructions section of the Reporting Bugs page for more info.)

    If the problem did happen again with showInConsole on, there would almost certainly be an error in the Error Console that would enable us to fix it quickly.
Sign In or Register to comment.