When Zotero “insert bibliography” in Word it isn’t italicized - but it should!

By chance Zotero started to behave in a strange way when inserting bibliography in Word. What should be italicized isn’t being showed (APA 6th style).

If I create a new document, the style in Word works perfectly. However, if I create a new document and I copy all the content of the file in which the style isn’t working properly, the problem is transferred to the new document.

I recorded the problem:

I would appreciate help to understand what is going on.

Thanks in advance!
  • the problem is the first reference. Due to a Word bug, italics get removed if the first reference is made up of more than half italics.
    The easiest workaround is to include a (fake) journal article reference by Abu Aardvark and then to delete it at the end.
  • Thanks! It worked.
    This is a very trick bug.
    Is it expected to be solved in forthcoming releases?
  • it's not a Zotero bug but a Word bug - so I don't think there's much Zotero can do about it, although I guess it might be possible to put in a workaround - but Simon would have to say.
  • I've tested Zotero, Endnote and Mendeley in same Word version (2013) + same document, using same style (APA 6th).

    Zotero presents the trick bug. EndNote and Mendeley work properly, since the field is italicized.

    Comparison here=> http://goo.gl/k8CETO

    Although it is a Word bug, somehow it seems to be attached just to Zotero.

    In this sense, a workaround/solution would be very welcomed.

    Is it necessary to open a ticket/request about this problem? How to?

  • It has to do with what Word does to the text when we apply the Bibliography paragraph style to the bibliography. Because a sufficiently large portion of the first paragraph is italicized, Word decides that applying the paragraph style should strip italics from the whole text.

    Mendeley doesn't apply a paragraph style to the bibliography (which means they have a bunch of people on their complaining that they can't change the bibliography spacing etc.). Not sure about EndNote.
Sign In or Register to comment.