Difficulty Syncing... Corrupted Zotero Login Manager Database

I am having difficulty with Zotero Standalone. I have Zotero version 4.0.16.

When I attempt to sync I get the following error

Error #1: "Zotero cannot access your login information, possibly due to a corrupted Zotero login manager database.

Close Zotero, back up and delete signons.* from your Zotero profile, and re-enter your Zotero login information in the Sync pane of the Zotero preferences."

When I attempt to login, I get the second error..

Error #2: "The Zotero sync server did not accept your username and password.

Please check that you have entered your zotero.org login information correctly in the Zotero sync preferences."

I have reset my password twice and reinstalled Zotero standalone.

No luck!
  • Did you do what the first message suggests?
  • Could you give me clearer instructions?
  • yes -- found the "signons.sqlite" in the zotero profile directory and deleted that file. also deleted one from a firefox profile directory. still no luck.

    ended up uninstalling zotero and reinstalling a clean version (no user data). still doesn't work.

    with the clean copy, and the new profile directory that is created, when running zotero, i NEVER see a "signons.sqlite" file show up.

    even removed chrome, thinking that somehow the zotero extension in chrome was making the problem. but the problem existed even without chrome.
  • Deleting signons.sqlite from your Firefox profile directory would've wiped out all your saved website passwords, FYI.

    Nothing to do with Chrome.

    When you return to the Sync pane of the preferences after closing it, is a password still entered in?
  • edited November 21, 2013
    To be clear, you won't see a new signons.sqlite until you reenter your password in the preferences. But if the file isn't showing up even after you do and close the prefs, something is interfering with Zotero. If you're running security software on your system, try disabling it.
  • regarding the firefox signons.sqlite...that's okay. we no longer use it.

    we've got security software. i disabled it, but i'm still getting the same error and the signons file does not get created.

    but it did get me thinking... when installing, norton flagged "freebl3.dll" and quarantined it. looks like it was found earlier today before all the problems started.

    could it be that this is the issue???
  • Yes. That file is part of Zotero (or, more accurately, the Mozilla framework Zotero uses). Uninstall Zotero, reinstall from zotero.org, and see if it's flagged again. Security software occasionally erroneously flags Zotero as a security risk due to the browser-related libraries it's based on.
  • thanks a bunch! it worked. i did have to override the security software to make it ignore that file. signons.sqlite exists and it connects up fine to the account!
Sign In or Register to comment.