APA In-text Citations adding author initials

Hello Zotero,

First, let me say how invaluable Zotero has been in writing my dissertation. I really love your program (and use it over the Refworks my university provides).

I am having a small problem. I have several author names that are showing up cited as (Initial. Author, Year).

For example, I have Ramlo cited many times in my dissertation, but in some citations, she comes up as (S. Ramlo, 2005) or (S.E. Ramlo, 2008). APA 6th shows it should just be (Ramlo, Date).

Is it because in my Standalone, I have Ramlo sometimes imported as S. Ramlo, sometimes imported as S.E. Ramlo, sometimes as Sue Ramlo? And I need to change them all to no initials so the program doesn't see it as different authors?

Thanks!
Amy
  • edited October 25, 2013
    Is it because in my Standalone, I have Ramlo sometimes imported as S. Ramlo, sometimes imported as S.E. Ramlo, sometimes as Sue Ramlo? And I need to change them all to no initials so the program doesn't see it as different authors?
    that's it, exactly.
  • Thank you so much! I thought I probably figured out the answer to my own question, as I typed it. LOL.

    I appreciate the quick response!
    Amy
  • To clarify a bit more, it doesn't matter if you change them all to full name, initials, or no first name at all (though I don't see why you would want to do that) as long as they are identical. Periods after the initials matter as well.
  • Though full first names are recommended in case you ever use a style requiring them.
  • Hi all,

    I, too, am having a similar issue and am not understanding the solution based on the feedback here. With multiple sources that include the same author, I've gone into my in-browser (Firefox) Zotero and changed all author listings for one author to be the same style (e.g.: "Corbett, K."). I'd hoped this would then change the various in-text citations to only show (Corbett, year). However, they all continue to show (K. Corbett, year) now. Are you advising that I just erase the first name/initial in the Zotero listing for each source? Or is there some way to change a setting for all in-text citations to not include initials? Thank you!
  • no, of course you can't erase initials -- you need them for the bibliography, among other things.

    Also, as I say just above, ideally you'd go with first full names instead of initials in Zotero, since many other citation styles prefer those.

    As for why this isn't working for you, hard to say. There are basically three possibilities:

    1.) There is indeed another Corbett cited as a first author somewhere in your work. In that case, K. Corbett is the correct citations

    2.) You missed one in Zotero. Note e.g. that Zotero is currently quite picky and will consider Corbett, K and Corbett, K. two distinct authors.

    3.) At least one of the references isn't linked to its corresponding Zotero item anymore but is instead updating from references stored in the document.

    You could look at the bibliography, which may help you identify 1 for sure and may even give you clues for 2 and 3 (e.g. if one entry is sorted in the wrong place -- but I'm not sure that would necessarily be the case). If that doesn't help, inserting them in a fresh document for testing would help to rule out 2. As a last resort for 3.) you can check item field codes by pressing (in Word) alt+F9 (alt+Fn+F9 on a Mac -- same key combinations to hide them again) to look at the bibliographic data Zotero is using for citations.
    Or switching to a different citations style -- Chicago autor-date, e.g., which uses full first names in the bibliography might be an option.

    I'd start by looking at the bibliography. I think authors

    First thing I'd try
  • Excellent - thank you so much. I think the issue was that I had one in-text citation that included multiple sources which featured Corbett and another author with different styled entries in Zotero. Once this latter author's "creator" listings were all switched to the same style in zotero, Corbett was then correctly switched to "(Corbett, year)".

    Thank you for the fuller explanation, and potential solutions, got it!

    Best,
    Todd
  • So I am having this issue, and have tried desperately to figure out what I am doing incorrectly. I've tried steps 1-3 that adamsmith suggested above. The citation information in Zotero is entered identically for the citations. When I use the citations in a new document, I have no issues at all. When I try to refresh the citation links in my original document and/or update using citations from my library vs. previous citations, I still have issues in my original document.

    I am having this issue on citations that do not share a year, only the same two authors. I am using APA, and my in-text citations are: "J. Arditti & Few, 2006" and "J. Arditti & Few, 2008" vs. "Arditti & Few, 2006 or "Arditti & Few, 2008".

    I am at a loss, and any help would be appreciated!
  • @dstillman : The two citations I'm having issues with are consistently and correctly entered into my library- at least as far as I can tell. I followed the instructions for the "Deleted Citations" on the link you sent, and that all checks out as well.

    Should I try to disable the name disambiguation?
  • @dstillman : I just copied the entire document and pasted it into a blank document, and the citations corrected themselves. For my purposes, this works to correct the issue so I can send this draft, but any idea about why this originally happened/what I need to do to prevent these issues in the future?

    Thank you!!
  • If you selected the same style, and it wasn't a question of disabling Automatic Citation Updates and not having yet clicked Refresh, then it shouldn't really make a difference, but copying into a new document can sometimes fix weird issues (which is why it's a standard part of the Debugging Broken Documents steps).
Sign In or Register to comment.