Zotero field codes not showing up in Word

None of the files (I version) are showing up the codes. None. I did not strip any of the files for the codes. I'm guessing this is an issue with a Word toggle or setting? Any suggestions on what to try? Thanks.
  • could you specify that a bit more? What exactly happens?
    Have you tried, e.g. inserting a bibliography?
  • It's as if I had not "stored references in document." Everything is just text, not fields. So my citations are there but as if I'd typed them. I have multiple versions of the article (I was revising and saving a copy each day) and none of them have fields. Since I used the previous day to build the next, and since each new day kept the fields, and since I never updated the older versions, it cannot be the case I converted fields into just text for all those documents. Kind of baffled.

    I need to revise the document again to submit to another journal and I can't just do it automatically.
  • So just to be clear, when you're clicking on insert bibliography, Zotero tells you there are no references in the document?
    We need you to be specific about what not having fields means here - you can turn off the grey shading of Word fields in Word so they wouldn't be clearly visible anymore, but still exist.
  • If I click on "insert bibliography" Zotero inserts {Bibliography}. If I go to a citation and click on "edit citation", I get the message "you must place the cursor in a Zotero citation to edit it."

    So, yeah, it doesn't see them as Zotero citations.
  • are those saved as .doc or .docx files? (shouldn't matter, but might help for troubleshooting).

    The only way I'm aware of that Zotero fields would ever get lost without explicitly deleting them is by either saving them in a format that doesn't support fields (like RTF) or by saving them in software that doesn't write fields (like LibreOffice or Google Docs)
  • I have not done either. Plus, I have multiple versions, one per day. I obviously managed to work on them as I kept updating the document, once per day. Totally baffling. Every single version of one project no longer has fields. It did while I was working on them for about a week.

    I just opened a brand new document and insert citation, edit citation, etc. works fine.
  • They are .docx, by the way.
  • Would it be possible to send one of the documents to support@zotero.org? Not really sure what to suggest otherwise.
  • Sure, I'll send it along a minute. I just opened an article I edited right after that one and the fields are fine in that (whew). If it is just that one, I can chalk it up to the Gremlins but it does suck to have to redo a bibliography to resubmit to another journal when you used Zotero to write it. :-)
  • Yeah, I'm afraid I don't have an answer for you. This is definitely plain text, though the document does have Zotero preferences in it.

    It's not really possible for Zotero to do this itself unless you use Remove Field Codes. I assume you would've done that when submitting it, though that wouldn't explain the earlier files, unless you did that and then made non-Zotero edits. Alternatively, have you checked the timestamps on the days' files to make sure they weren't updated at a later date?
  • (If you're on a Mac with Time Machine—or otherwise have similar automated backups—you could also check for previous versions of the files to see if they changed.)
  • I'm on a Windows and I do versions myself. The timestamps are fine. I leave behind the previous day and move on to the next one.

    I could recover backups but it might be quicker just to redo the fields given it's not that complicated the document. I'm just baffled and a little worried about not understanding what happened.
  • Is there a way to view all the field codes that are in a specific document and toggle to each one in word? I have some citations that I can click on and they will highlight gray and others have no activity like I manually typed them in. When I add new citations they do adjust the numbering of the inactive citations. I'm not sure how to identify the problem.
  • @lady112017, assuming you're on Windows, you can use F11 and shift-F11 to move between fields, and alt-F9 to toggle field code display in the document (see http://www.officetooltips.com/word/tips/field_keyboard_shortcuts.html).
  • Thank you Rintze! That helped me to resolve my issue fairly quickly.
Sign In or Register to comment.