can't see attached file on online platform

I apologize in advance if this question has been discussed before, but I can't find anything that answers my question in this forum.

My question: If I access my library online directly via the zotero website, sometimes I can see the attached pdf to an item, and sometimes I can not...even though I surely havn't changed that file/item in a long time and it surely contains an attached pdf. It seems that I can either see all of my attachemts of all my items, and then on other days I can't see any of them. On my computer based library they of course are always there.

Is there something that I'm doing wrong or that i messed up in my settings?
I would greatly appreciate any help. Thanks in advance!
  • Assuming this is not a case of being logged in vs not, this may be a browser incompatibility. Are you always using the same browser? If not what browser is it broken on?
  • Thank you very much for your quick response!
    Yes, I'm definitely logged in, but now that you mention it, it could very well be that I usually notice this problem whenever I try to access my pdfs from the computers at the company where I'm at today. And a few days ago, when I also couldn't get my articles, I tried to access them from the computers of another big coorporation with probably lots of security settings in their IT system.
    The browser here is Windows Internet Explorer 9, Version 9.0.8112.16421

    Could that really be the problem? It's not that I just can't open the PDFs or get some security block warnings...everything looks totally normal in my Zotero library, i can see all my collections and items and i can see the URL links etc, except that the PDF attachments are nowhere to be seen..meaning it doesn't even indicate that usually an attached file exists to that item.

    And if that's the problem, I probably can't do much about it except asking the IT-guys here to install another browser and/or changing some security settings, correct?

    Thanks again for your help.
  • Most of the library interface uses javascript if it can. It falls back to non-javascript if it needs to, but it doesn't load the child items the same way in that case.

    There was an issue fairly recently on IE that caused this problem, but as far as I know that is fixed (and it was only for a few days). I can't test on windows until tonight.

    Unless the security settings are affecting javascript (which would break a lot of sites these days) they shouldn't be the problem.

    What browser do you normally use? And just to narrow down conditions is this your own personal library, a group library, or both?
  • I usually use Safari on a Mac, but I don't log into the Zotero website very often but work directly with my standalone version.

    I just logged in via Safari and I can see and open all the attachments that I couldn't access this afternoon from my workplace with the windows computers and internet explorer.

    As far as I can tell, when I click on an item, everything looks exactly the same on both browsers, but on the IE browser on the very bottom "notes and attachments" is completely missing, and I don't remember seeing the button "upload attachment" this afternoon either. If I'm not mistaken, "Tags" was the last thing on the bottom of the page.

    Affected were both, my personal library and my group library. But I'm also the owner of the only group library that I'm a member of (in case that makes a difference).

    Thanks so much for your time
  • FYI...On the IE browser, I can also not see any TAGs on the left below my library. It says TAGS, but then there is just an empty space...and I definitely have tags.
  • Has anyone else experienced the same problem as described above?
    Is this really a browser incompatibility and are there any other solutions short of installing a different browser?
    Thanks a lot if someone has a suggestion
  • I can reproduce this in IE 10 if the privacy settings are turned up higher than Medium. The only apparent difference between Medium and Medium-High is a change from "Restricts first-party cookies that save information that can be used to contact you without your implicit consent" to "Blocks first-party cookies that save information that can be used to contact you without your implicit consent"
  • I have a similar problem when I use my nexus 7, chrome browser, to access my zotero library (full site) from server. I have the 'Tags' with relevant key words but no 'Notes and Attachments' where my pdfs or pdf links should be. I used to be able to access the pdfs without any issues about 3-4 months ago. My last download of pdfs from files.zotero.net using my tablet was on 18 Sep 2014.

    I tried to change privacy settings on the browser, accept cookies, cleared caches, etc. and nothing seems to be working. I've posted a similar forum and was asked to check sync issues. All other laptops, standalones are working fine -- no sync issues or missing pdf links from zotero.org

    Any insights or suggestions?

    Thanks!
Sign In or Register to comment.