WorldCat imports books as webpages

Why, when I import books from WorldCat, does Zotero make their "Item Tye" "Web Page" and not "Book"?
  • This usually happens if Zotero does not recognize the page as WorldCat (most likely because of proxy), but does pick up I some metadata embedded in the page. What URL are you importing from (exactly as you see it)?
  • Here's an example:

    When I click the book icon in FireFox's toolbar to "Save to Zotero (Open WorldCat)", it creates a webpage entry.

    This one imports correctly as a book:

    I think the issue is that whenever I try to import e-books from WorldCat, Zotero considers them webpages.

    Importing using COinS doesn't have any of these issues.
  • edited September 7, 2013
    Is this because it is an ebook? IN the RIS, TY is ELEC.
  • Yes, WorldCat exports ebooks as ELEC. We'll fix this.
  • The fix is now live. You can update your translators via Preferences -> General -> Update Now.

    Let us know if there are further issues.
  • The latest is 4.0.12? If so, I still get the same problem.
  • translators update separately every 24hs, they're not tied to a Zotero version. You can trigger the update immediately by clicking on the "Update now" button in the general tab of the Zotero preferences.
  • Yes, it works now! Thank you very much!
Sign In or Register to comment.