bug in neooffice citation plug in with chicago manual of style (notes with bibliography)


i found what seems to me a small bug in the citation logic of the zotero plug in for neooffice. I use Neooffice 2.2.3 patch 5, the zotero firefox plug in 1.0.4 and the zotero-neooffice plug-in 1.0b3 and the citation-style "Chicago manual of style (notes with bibliography):

When I cite the same book twice consecutivly the anotation apears the second time as "Ebd". That is correct.

But sometimes I want to write somthing more in a footnote than only the data of a cited book...

When I insert manually a footnote, it is a footnote without a book citation that is generated by the zotero plug in, between those two citations generated by zotero the numbering of the footnote is correct while the second citation generated by zotero is still "Ebd".

Even worth: If I insert in the manually inserted footnote a citation of a different book generated by zotero the second citation of the former book still is "Ebd".

Even more confusing: If I insert a further footnote after all of this footnotes manually citing again the second book it also appers as "Ebd".

When I insert after that one las footnote with the latter book it correctly shows again "Ebd".

In result the switching between footnotes entirely generated by the zotero-plug-in and footnotes manually inserted into the text gets zotero confusing the correct "follow-up" of the citations.

This may seems a minor problem, but at least I really need some times possibillyty to add some text into the footnote that extend the simple information about a cited book.

I don't know if it is easy to fix this bug, nor do I know if the problem is the citation-style definition or the logic of the plug in (I suppose the latter) but I would realy apreciate if someone could fix the problem.

all the best
  • Hi,

    I just got the latest neooffice patch 6. After installing this patch the zotero plug-in worked perfectly right. So maybe it was not an zotero bug but a problem of interaction with neo office. Anyway the problem is solved!

Sign In or Register to comment.