Zotero Standalone 4.0.10 file sync error

hi,
updated to 4.0.10, started showing error while syncing.
on the firefox addon no error appears.
report ID: 106863715

thanks!
  • edited August 8, 2013
    [JavaScript Error: "Error undefined E:\[...]" {file: "chrome://zotero/content/xpcom/storage.js" line: 1064}]

    Can you provide a Debug ID for a sync attempt that produces this error?
  • Also, is E: a network drive or another local drive?
  • thanks for the fast comments.

    D227681095
    D is a local drive
  • edited August 8, 2013
    malte12: If you happen to have Zotero for Firefox installed, can you confirm that this also doesn't happen in Firefox for you? (If you don't have it installed, don't worry about it.)

    (3)(+0000030): Mod time didn't match (1375975990622!=1367780007641)
    but hash did for undefined for item 0/2D6W5P7R -- updating file mod time

    (3)(+0000001): 'name' => "NS_ERROR_FILE_IS_LOCKED"
    'QueryInterface' => function(...){...}
    'message' => "Component returned failure code: 0x8052000e
    (NS_ERROR_FILE_IS_LOCKED) [nsIFile.lastModifiedTime]"
    'result' => 2152857614
    'filename' => "chrome://zotero/content/xpcom/storage.js"
    'lineNumber' => 1029

    Do you happen to have any PDF files open on your system while you're trying to sync?
  • - Firefox Addon is installed (but i have no error message in firefox)
    - other pdfs are open
  • I closed the pdf reader an did try it again. The message persists.
  • Just to be sure, can you try restarting Zotero after closing the PDF reader?
  • Ok, now i closed the PDF reader as well as Zotero and Firefox. Opened Zotero but still the same error message.
  • Same here - Debug ID: 1424968125

    Thanx for working on it Dan!
  • Mhirsch: That's actually a Report ID. Could you provide a Debug ID for the sync attempt? Just want to make sure this is the same underlying issue.
  • Oh, sorry... update:

    Das Protokoll zur Fehlerdiagnose wurde an den Zotero Server ├╝bermittelt. Die Protokoll-ID lautet D1226328472.
  • here is mine:
    The Debug ID is D2020618775
    E: is local drive

    many thanks!
  • in my case - no pdf reader or any pdf file opened since computer start up.
    also - similar error in my home computer...
  • OK, this should be fixed in Zotero 4.0.11, available now. Sorry for the trouble.
  • Thank you very much Dan & team.

    4.0.11 works fine for our group as standalone & firefox add-on.

    Great work!
  • Thanks, the error message is gone!
  • I had the same problem after upgrade to 4.0.10. Report ID = 739728050. Works fine after upgrade to 4.0.11.
Sign In or Register to comment.