I can't find Zotero Connector in Chrome

I have installed, uninstalled, and reinstalled many times Zotero Chrome Connector. It's not working on Chrome. What gives? I have the most up-to-date version of Chrome running. Thoughts? This problem is very frustrating.
  • It's not working on Chrome.
    What do you mean exactly ? What's not working ?

    If you think that you managed to install Zotero extension for Google Chrome, check this page: http://www.amazon.com/The-Wealth-Nations-Adam-Smith/dp/161382081X/ref=sr_1_1?ie=UTF8&qid=1368761818&sr=8-1&keywords=adam+smith You should see a Zotero URL bar icon (a book)
  • I dont see it on that page. But I have Zotero Connector installed. I check my extensions and it's there and enabled.....
  • which Chrome version specifically?
    Are there any errors reported by the chrome connector as described here:
    http://www.zotero.org/support/reporting_bugs#provide_a_report_id ?

    If you right click in any page, do you get a "Save as Zotero Snapshot" in the context menu?
  • edited August 1, 2013
    So, I can get Zotero snapshots when I right click.

    here's my error report:

    [JavaScript Error: "Cannot read property 'id' of undefined" {file: "chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/background.js" line: 75}]

    [JavaScript Error: "Attempting to use a disconnected port object" {file: "miscellaneous_bindings" line: 61}]

    [JavaScript Error: "Cannot read property 'id' of undefined" {file: "chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/background.js" line: 75}]

    [JavaScript Error: "Attempting to use a disconnected port object" {file: "miscellaneous_bindings" line: 61}]

    [JavaScript Error: "Cannot read property 'id' of undefined" {file: "chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/background.js" line: 75}]
  • I'm not sure if any of those errors are related to the problem you're experiencing. Please follow the steps below:

    1. Restart Chrome
    2. Go to the Amazon.com page linked above
    3. Go to chrome://extensions/
    4. Check the "Developer mode" button in the upper right
    5. Click "_generated_background_page.html" under Zotero Connector
    6. Ensure that Console is selected in the window that opens
    7. Select the contents of the window and copy it
    8. Paste the text into an email and send it to support@zotero.org
  • I send the email yesterday! I look forward to seeing if you can make heads or tells of this conundrum...
  • I'm having the same problem, except that the Connector has been working just fine for me all summer, and suddenly the book icon has disappeared. When I try to download the connector again, the Chrome store tells me it's already installed.
  • same questions as above - which versions? does right-click --> snapshot work? Do you get any errors?
  • I am having the same problem. I just sent an email per your instructions below to support. However, I also tried turning on the logs in Extension Options. It appears that the problem has something to do with loading translators as when accessing a Google Scholar page after a search I get the debug output below for every search result on the page. I also see "Looking for translators" if I try to use the bookmarklet instead. Hope this helps solve the problem as not being able to import citations is just about killing me, really I do it all day long :-)

    (3)(+0000000): Setting debug.store to true

    (3)(+0017767): Translators: Looking for translators for http://scholar.google.com/scholar?q=An+activity+theory+approach+to+memory&btnG=&hl=en&as_sdt=0%2C47

    (3)(+0000001): HTTP POST {"translatorID":"57a00950-f0d1-4b41-b6ba-44ff0fc30289"} to

    (3)(+0000838): Translators: Looking for translators for https://apis.google.com/_/+1/fastbutton?bsv=o&usegapi=1&size=small&annotation=inline&hl=en-US&origin=http%3A%2F%2Fscholar.google.com&url=http%3A%2F%2Fscholar.google.com%2Fscholar%3Fq%3Dinfo%3Ac92fiQAj43AJ%3Ascholar.google.com%2F%26output%3Dinstlink%26hl%3Den%26as_sdt%3D0%2C47%26scillfp%3D17418483439665284237%26oi%3Dlle&gsrc=3p&jsh=m%3B%2F_%2Fscs%2Fapps-static%2F_%2Fjs%2Fk%3Doz.gapi.en.l49lMhuyXyk.O%2Fm%3D__features__%2Fam%3DEQ%2Frt%3Dj%2Fd%3D1%2Frs%3DAItRSTOvD2NxxPLz0HiGHMXTek7IhOVTHg#_methods=onPlusOne%2C_ready%2C_close%2C_open%2C_resizeMe%2C_renderstart%2Concircled&id=I0_1377299602936&parent=http%3A%2F%2Fscholar.google.com&pfname=&rpctoken=34214739
  • I seem to have solved the issue. Perhaps this might help the others. I closed the standalone application. Closed my browser. Re-opened the browser and went to Extensions and disabled the connector. Closed and reopened the browser again. Went back into Extensions and re-enabled the connector. Went to a page (Scholar) that should show the Zotero icon in the URL bar -- Voila, it was there. Re-opened the Zotero desktop and it was able to connect!
  • I'm having a similar problem with not having an icon in Chrome. I have already spent way too much time trying to figure this thing out. i really need this program to work the way it claims to.

    I have all up to date versions of Chrome and Zotero. When i go to download the extension from the site it said it's already downloaded. i tried turning everything off, reseting, turning everything back on. Still no icon. Tried the command click thing to find the Z and tried saving it that way, but now it doesn't even show up in my library even though it said it's saving.

    also found this error: [JavaScript Error: "Attempting to use a disconnected port object" {file: "miscellaneous_bindings" line: 51}]

    Also, in the extension manager, does the 'allow in incognito' option need to be selected?

    What am i doing wrong?
  • Do you have Zotero Standalone installed?
    Did you try on the amazon page linked to above?
    Also, in the extension manager, does the 'allow in incognito' option need to be selected?
  • Yes, i have Zotero Standalone 4.0.11 and tried the amazon page link. i dont see an icon anywhere.
  • when you click on "Options" for the Zotero Chrome Extension - It should say whether Zotero Standalone is offline or online - which is it?

    Then, provide a debug ID from the Chrome connector for the process of first loading the amazon page above and then trying ctrl+click --> Save as Zotero Snapshot http://www.zotero.org/support/debug_output#zotero_connectors_chrome_and_safari
  • also please confirm the version nos of Chrome and the Zotero Chrome Extension as well as your OS.
  • it said:
    Zotero Standalone is currently available.

    Debug output has been sent to the Zotero server. - The Debug ID is D704453795.

    Not sure what nos is, found this:
    Version 29.0.1547.76 - Google Chrome is up to date.
  • great and this in on Mac? which OS?
    @Dan - anything in the debug?
  • edited September 27, 2013
    The debug output shows a successful POST to Standalone with the data from that page.
  • edited September 27, 2013
    you mean the citation data? But that can't really be if there was no URL bar icon? Or what am I missing?
  • Sorry, not really following along. The output shows a successful save of that page's snapshot data to Standalone, but that's it. No bibliographic data, and nothing regarding loading the page, etc. (I don't know off-hand what the connector shows during a page load, but if it shows anything, it's not in the output.)
  • it should show something along the lines of:
    - looking for translator for www.amazon.com...
    - binding to sandbox

    If it doesn't, my guess would be that the debug just didn't cover loading the page, but there might be another reason this could fail to happen.

    @roxxa888 - are you positive the item isn't in your Zotero library (as a webpage)? Have you sorted by date added to make sure?
  • there is a url in Standalone but there is no info about the book. i cant just use a web link in a biblio. when i was shown this program in school, our instructor was extracting lots more info about the citation.
    I also tried using it from JStor. Same thing only a link to the website, not the details of the publication.

    and there is still no icon in Chrome. i'm doing al this through command button.
  • so i just tried adding a citation in Word using Zotero. and it seems to add the details in the footnote there- edition, year, pg#, etc. But why cant i see anything in my Z library? shouldn't i be able to see details there for categorizing and searches later as the list starts to grow?

    i tried to go through the tutorial but i lose it at the icon selection, because i dont have one at the bottom of my screen. so i'm not seeing what the tutorial is showing.

    i also plan on using this with Scrivener. Havent even gone there yet. i hope that works.
  • forget the Word plugin for the moment, that's just going to be a distraction.
    While we're troubleshooting, it's important for you to be as precise as possible in what you tell us - we can't see what's on your screen, so all we have is the info you give us.
    Earlier on you said
    "Tried the command click thing to find the Z and tried saving it that way, but now it doesn't even show up in my library even though it said it's saving."
    So we were troubleshooting that.
    That's now working, apparently. That you're just getting the webpage item type is expected for that option, but it's good to know it's working.

    We need another debug ID. This time please make sure you have logging turned on _before_ you load the amazon page.

    Also, try disabling all other Chrome Extensions for troubleshooting.
  • okay, turned off all other extensions, turned on logging in Z, clicked amazon link and sent the debug report...The Debug ID is D1380435410.

    and thank you btw, i really appreciate your time. i'm at the beginning of a one year thesis research project so this is important.
  • Dan - anything in the debug now?
    Also, is this the debug from Zotero Standalone or from the Chrome extension (I'm looking for the latter).
  • (3)(+11343960): Translators: Looking for translators for

    (4)(+0000075): Translate: Binding sandbox to

    (4)(+0000001): Translate: Parsing code for Amazon.com

    (3)(+0000003): Translate: All translator detect calls and RPC calls complete

    And then some more about ad.doubleclick.net and other iframes. Looks OK to me, but the debug output doesn't actually say which translator was chosen for the icon—or whether the icon is displaying at all—so I don't think this is particularly useful. (It'd be good to make it log that.)

    roxxa888, just to make sure we're all on the same page, where exactly are you looking for an icon?
  • been looking everywhere at this point. but started with lower part of the screen as the tutorial showed. where should i be looking?
  • there should be a blue book icon at the right of the URL bar

    The icon at the bottom of the screen is for Firefox only and just opens the program.
This discussion has been closed.