Error Changing Citation Style (Report 654683638)

Hi all,

I’ve encountered an interesting problem when trying to change reference / citation style. First, here’s the set-up:

Firefox 22.0 & Zotero client 4.0.9
Windows 7 x64
Microsoft Word 2007 (.docx)

Chicago (full note) is my default citation style. I’m using endnotes and fields currently. In my document, I noticed that citations with multiple sources were showing up with one endnote. The sources themselves were separated by semi-colons in the endnote. I didn’t think this was standard behavior, but I wasn’t sure, so I wanted to double-check by changing reference styles. When I tried changing styles, I received one of two errors.

When changing to a few different styles (like the American Journal of Tropical Medicine and Hygiene), I received a pop-up error message. There was trouble updating the document. I’ve attached a log from Zotero (below) and submitted a report (#654683638). Here is an image:

When changing to AMA, my endnotes lost their bibliographic information. Instead, they displayed the number of the endnotes themselves. Here is an image:

I’ve already tried some of the standard document diagnostics, including ensuring that track changes are disabled, duplicating the document, and copying the document contents into a new file.

Please let me know if you have any ideas or if I can provide additional information. Thanks!

Zotero log (Report 654683638)

[JavaScript Error: "this.docShell is null" {file: "chrome://global/content/bindings/browser.xml" line: 323}]

1374510493451 Services.HealthReport.HealthReporter WARN No prefs data found.

[JavaScript Error: "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [zoteroIntegrationDocument.convert]" {file: "chrome://zotero/content/xpcom/integration.js" line: 1224}]

No chrome package registered for chrome://dta-modules/content/support/filtermanager.js
  • The Chicago Manual Endnote behavior is standard and correct according to CMoS.
    The AMA behavior is also correct - AMA doesn't use endnotes, you can see the bibliography (which is what you call endnotes in this case) by clicking insert bibliography. (This is in fact a numerical bibliography - endnotes are always consecutively numbered, whereas recurring items in a numerical citation style/bibliography are referred to by the same number when they re-occur).
    Simon will have to weigh in on the document update error.
  • edited July 22, 2013
    Thanks Adam. To clarify, I realize that AMA avoids endnotes and uses a numbered references list instead, which can be created as a bibliography with Zotero. I did not have any problems producing a bibliography in this example (not shown). However, the endnotes themselves are retained after I shift styles. These endnotes then show the unusual behavior of displaying their numbers (as seen in the image). This struck me as related buggy behavior, so I listed it with my explicit error message to facilitate troubleshooting. Of course, this could be something caused by Word's handling of endnotes, but I wanted to disclose it to provide fuller context.

    Thanks for any additional comments and ideas.

    Edit: Perhaps related, but when I shift to a style like Vancouver, new citations will display appropriately. But the old citations keep their superscript formatting. Intriguing.
  • Sorry, didn't look at the pic.
    Zotero should be able to handle this correctly, assuming you added the Endnote with Zotero directly (rather than creating it with word and then inserting the citation into it with Zotero).
    Simon will have to take a look.
Sign In or Register to comment.