[solved] Moved data dir -> now wants to re-upload all items

Hi there,

All I did was moving my data dir of my Zotero Standalone from its default location to:


In the Zotero settings I point to exactly that location. It contains a folder "storage" with all my items. Nevertheless, when starting the sync process, Zotero wants to re-upload all items to my webDav.

Can someone please tell my why it does not recognise that all elements are still there both locally and on the server?

The debug output: http://www.file-upload.net/download-7826549/debug.html
  • If the mod times on the files changed—e.g., from some methods of copying rather than moving—it would recheck all the files.

    But in that debug output it doesn't look like it's actually uploading anything, just checking all the files and determining that the mod times match the remote files. (At least, for the few files it tried. I believe you cancelled it after the first few?) That shouldn't happen if all you did is change the data directory and everything was in the right place, so I can't tell you why that's happening, but it should finish pretty quickly.
  • Thanks Dan.

    Indeed I cancelled the sync process very quickly after Zotero had showed me (hovering over the sync button) that it wants to upload hundreds of files. But if that really just means that it is comparing the timestamps, then I will let it complete the sync process and see whether it actually re-uploads them or not.

    But yes, I just moved the entire directory.

    I will let you know how it goes.

  • You were right Dan. Even though Zotero was displaying that it is uploading several hundreds files (which would mean my entire library) it was just uploading the new ones.

    Yet there were a few sync warnings with local and remote files apparently differing. I do not know why though.

    Anyway, problem solved. Thanks!
Sign In or Register to comment.