Once again, Zotero not working on Windows 8

This has happened before, but now I do not know how to fix it. When I click on a new citation, no Quick Citation dialog box comes up. It says citation down below at the bottom of the page, and a BLANK firefox dialog box appears at the bottom of the computer screen.

Before I disabled the Endnote applications on Word. But they are still disabled and it is still not working.

I closed the document and reopened it. I restarted Firefox. I have the most updated version.

When I go to zotero.org it will not let me re-download the winword plug in. It is blocked.
  • Try disabling all other Firefox add-ons. IIRC someone reported that the Word 2013 installed in Firefox can cause this. Could also be other Firefox add-ons.
  • Thanks Adam. I did that and no change.
    I removed and redownloaded both Zotero and the winword plug in. I think this problem has something to do with Windows 8 and Zotero because these extensions would not download on Firefox. I had to download them on Chrome.
    Then, I went to Preferences of Zotero and clicked use classic dialog box and now it works. But only the classic. The Quick Citation Dialog Box does not work.
  • Could you elaborate on how the install in Firefox did not work. That's doesn't have anything to do with the Windows version you use & shouldn't be the case.
  • Yes. I have made sure that the Firefox is updated and even tried reinstalling it. But the download of Zotero has never gone through. When I click download, for a second something flashes on the tab at the top of the browser and then nothing happens. It is not in the download list of the browser either. I tried to manually drag and drop into the address bar and that did not work either. Other things on the Firefox are not working properly as well. Normally when you download something the green arrow on the top right corner lights up and then a dialog box comes up and tells yo the download is complete. That does not happen. I have to open up the downloads tab on the browser to access the download. The bookmarking feature does not work. I have to manually move each bookmark into its appropriate space.

    None of this has ever happened on my Windows 7 computer at my office. It is something about Windows 8 and Mozilla and Zotero and Endnote. Based on what I have seen of Windows 8, it is all about Microsoft closing up its system like Apple and not allowing add-ons and customizations. Am I paranoid?
  • That sounds like your Firefox install is broken. I'm pretty sure that's not a general Windows 8 issue, but it's likely something that people at mozilla will be much better set-up to support than Zotero.
    It's at least possible the QuickFormat weirdness is related to the same issue. One thing you could try is a fresh Firefox profile:
  • My Zotero word plug in was working fine till this afternoon. Suddendly it is not responding.
  • manindra: Please start a new thread, and provide more details.
  • I have reloaded the zotero firefoc and it has started working. Downloading the standalone, hopefully it would work.
Sign In or Register to comment.