Wiley Online Library: Not working with proxy

Using without an proxy works.

Error log (replaced proxy address with PROXY):

4)(+0000000): Translate: Parsing code for Wiley Online Library

(3)(+0000003): Translate: Beginning translation with Wiley Online Library

(3)(+0000001): HTTP POST doi=10.1002%2Fmrm.1910030410&fileFormat=BIBTEX&hasAbstract=CITATION_AND_ABSTRACT to http://PROXY_HOST/documentcitationdownloadformsubmit

(3)(+0001380): Translate: Creating translate instance of type import in sandbox

(4)(+0000000): Translate: Binding sandbox to http://PROXY_HOST/PROXY_DIRECTORY/onlinelibrary.wiley.com/doi/10.1002/mrm.1910030410/abstract

(4)(+0000002): Translate: Parsing code for BibTeX

(3)(+0000054): Translate: Beginning translation with BibTeX

(3)(+0000011): Translate: discarded item from BibTeX; type was

(3)(+0000046): Translate: discarded item from BibTeX; type was

(3)(+0000047): Translate: discarded item from BibTeX; type was

(3)(+0000039): Translate: Translation successful
  • is this on Firefox or using Standalone? Also, if you can post the actual proxied URL that'd be helpful, it's not like that's security relevant information.
  • Hi,

    I have also a problem that the wiley online library causes a translater issue. It first begins to with showing the error message, then it continues loading and stops after six papers.

    Current Versions:
    Version 27.0.1453.116
    Zotero Connector
    Standaline Zotero: 4.0.8
  • could you provide a URL where that happens exactly as you see it?
  • tl0
    edited July 8, 2013
    Because the URL alone won't help:


    I entered only the Terms "Big data" and used select all on the upcoming zotero item collector.

  • but that is the search URL as you see it? You're not removing any proxy or so from it?
  • I didn't remove anything.
    You should get the same URL if u place the search terms and press search.
  • and you can consistently replicate this? Works for me on Firefox, I don't have Chrome here to test right now.
  • Well I tried it now only from one pc but from different internet locations.
    And yes I can consistently replicate this with the software written above.
    Might be helpful: I use Windows 8
  • OK, either Aurimas will take a look or I'll get to this when I have my Chrome set-up back, which may take a little.
  • It's a Chrome issue (maybe Safari too).
    Translate: Translation using Wiley Online Library failed:
    string => TypeError: Cannot read property 'href' of null
    stack => TypeError: Cannot read property 'href' of null
    at Object.Zotero.Translate.Sandbox.Base._itemDone (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero/translation/translate.js:135:60)
    at Object.Zotero.Translate.Sandbox.Web._itemDone (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero/translation/translate.js:643:34)
    at Object._itemDone (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/inject/translate_inject.js:82:17)
    at Zotero.Item.complete (eval at <anonymous> (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/inject/translate_inject.js:50:9), <anonymous>:1:284)
    at eval (eval at <anonymous> (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/inject/translate_inject.js:50:9), <anonymous>:320:11)
    at chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero/utilities_translate.js:321:5
    at _stateChange (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/http.js:161:7)
    at XMLHttpRequest.xmlhttp.onreadystatechange (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/http.js:55:5)
    url => http://onlinelibrary.wiley.com/advanced/search/results?start=1&resultsPerPage=20
    downloadAssociatedFiles => true
    automaticSnapshots => true

    At this point, Chrome is trying to convert the document object that we store for Snapshots to plain URLs. I have a feeling that the document object for that particular page is being destroyed before we're able to fetch the URL (maybe Simon has a better idea).

    We could (at least temporarily) have the translator store url instead of document object during translation.
  • tl0
    edited July 10, 2013
    Well, good to know.
    But with Firefox it works? Then I can at least switch for this library to FF.
    Let me know when you fixed it ;)

    Edit: I figured out another problem that the zotero icon on the URL bar doesn't show up on SpringerLink (http://link.springer.com/) when you enter a search term and go to the second page. It works only on the first page.

    This problem occurs at Chrome and Firefox(Version 22 + newest Zotero Extension)

    Also this link doesn't let the export item show up:
  • Hi,

    as I see the error with Springer as described above is still there. Will there be a fix?
  • Sorry, had forgotten about this. Should be fixed now. Update your translators via Preferences... -> General -> Update Now
Sign In or Register to comment.