Same author for 2 resources, one removed from biblio, only dashes for name on remaining entry

Hi, I've created an automatic bibliography from citations in the body of an essay. However, some citations are for online resources (websites), and I only want printed books in the biblio. I edited the biblio to remove all websites. However, for one author, the second biblio entry has no name, just dashes. Yet, when I remove the first entry, the other one now on its own shows no name, just dashes. Essentially, when one entry is removed from the biblio, the logic on inserting dashes does not see this but continues to insert dashes anyway for the only remaining entry by that author. I've had to abbreviate one entry from John to Jn to force it to see different authors. Is there a workaround or solution to this?
  • I'm having the same problem: I removed one work from my bibliography, and now all that author's other works have dashes in place of the author's name in the bibliography. Has anyone found a solution to this?
  • Are you editing the document directly in Word, or are you making the changes in the Zotero interface/add-in and then letting Zotero recreate the Bibliography?
  • The latter: I'm making the changes within the Zotero interface.
  • Which citation style are you using?
    This can be actually intended by the style. Can you copy a sample here?
  • I'm using the style of the Pontifical Biblical Institute, authored by Fr. Devin Roza. Here's a sample in which the author E. Vineis does not appear because I have another Zotero entry that includes just one part of this three-part article, which I have removed from the bibliography.

    VETUS LATINA-INSTITUT, “Vetus Latina Database” (2017)
    ––––, “Studio sulla lingua dell’Itala”, ItD 34 (1971) 136-248; 36 (1973) 287-372; 37 (1974) 154-166.
  • the replacement by ---- is deliberate by the style as set by the argument subsequent-author-substitute="true".

    Can you double check how the data is entered in your Zotero?
  • But it sounds like the author doesn't appear at all in the bibliography, so that's not right, of course.
    I'd start by deleting the bibliography and re-inserting it.
  • Thanks, adamsmith. You're right: the author doesn't appear in the bibliography at all. I already tried deleting and re-inserting the bibliography, to no avail.
  • How were the page spans and years inserted into the entry? Are those entered in a field in the Zotero database?
  • damnation: Perhaps another example would be helpful. Note here that the second item is authored by Gryson, not Graves. In footnotes I cite separate Zotero entries for Gryson, which include only one of the two volumes that are shown here in the bibliography. I removed the single-volume entries from my bibliography, which makes it look as if Graves authored Gryson's work.

    GRAVES, M., “Vulgate”, THiB. Overview Articles (Leiden – Boston 2016) 1A 278-289.
    –––– (ed.), Esaias (VL 12; Freiburg im Breisgau 1987-1993, 1993-1997) I-II.
  • (1) If the changes were made by editing the bibliography (not citations) through the Zotero interface, refreshing the bib will lose the changes, but my bring back the author.

    (2) If the bib was not edited with Zotero, try switching to another style, then back. That should definitely clear it.

    If (2) is the case, and switching styles fixes it, let me know. I wouldn't expect this to be caused by a processor bug, but you never know.
  • Yet another thing to try would be to use "edit bibliography" and then "Revert all"
  • fbennet: The ranges of years were entered in the "Extra" field, as per the style of the Pontifical Biblical Institute.
  • To avoid confusion, my note (1) above refers to the same step described more clearly by @adamsmith.
  • @adamsmith: Thanks for the tip. I just tried it, i.e. "Revert all" followed by the addition of the non-cited entries containing the year ranges and multiple volumes, followed by the removal of the single-volume entries. This was all within the "Edit Bibliography" dialogue. Unfortunately, it only produced the same result.
  • Oh I didn't catch that -- so you're using edit bibliography to remove items from the bibliography? I'm not surprised that's causing weird results with author substitutes, not sure if we'll have a fix for that (or even exactly what expected behavior is here)
  • Thanks, @adamsmith. At least I know that I'm not missing some simple fix. What I intend to do now is to continue adding to the bibliography the non-cited versions that I want to include, and then manually delete the unwanted entries later on. I will wait until I've finished my document to break the field codes and take this step.
Sign In or Register to comment.