Standalone "not responding" -- due to synch?

For quite some time now, I've had problems with Zotero Standalone freezing -- or "(not responding)". Basically, whatever I do in Zotero will get interrupted, sooner or later, by the 'not responding' freeze -- very frustrating. I can see no clear pattern in when this happens: It happens when I'm searching, editing references or adding notes, or adding/editing citations in Word. But perhaps it is somehow related to Zotero's frequent database synching (OTOH; sometimes Zotero synchs without the freeze).

Any ideas on how I can resolve this problem?

I'm using Zotero 4.0.8 on Windows 7.
  • You're hitting your file sync quota, and you should be seeing an error saying as much. It shouldn't cause a freeze, and I'm going to try to fix that, but if you disable file syncing for your personal library in the Sync pane of the Zotero preferences this should go away. (You could also add a storage storage subscription if you wanted to sync the remainder of your files.)
  • Thanks! Turning off file sync seems to have partially solved the problem as I'm experiencing fewer freezes now.

    But Zotero still freezes every now and then when I, for instance, edit a note or a reference. Any ideas?
  • Did you disable file syncing completely, or just for personal libraries? You'd actually probably need to do the former.

    If you're still getting freezes with file syncing completely disabled, I'd need a Debug ID for a sync that causes such a freeze.
  • Yes, I disabled both My Library and group libraries syncing, but I still get occasional freezes.

    However, disabling automatic sync seems to have removed much of the problem, but I still get freezes for instance when searching the library.

    For instance, in this bug report (D2132683768), the search for "binder" causes a "(not responding)" freeze, but not the two previous searches.
  • I definitely see a hugely long delay there—16 seconds—but I don't think that's reproducible, is it? I see a "binder" search in there without a delay as well. So I'd actually guess that the delay is from something else on your system that occasionally causes Zotero's disk access during searches to be much slower. I can't think of any reason why some searches would be slower than others.

    I'm happy to look at additional Debug IDs that demonstrate the issue, though.
  • So I'm still on the same basic set-up and now experiencing slow-downs or freezes, especially when searching (either directly in Zotero or when adding references via the Word add-in).

    Just a thought: Could the problem be caused by storing the Zotero files on a network drive (on my local network), rather than on my local computer?
  • Absolutely. You should copy your data directory to the local drive, point Zotero there, and see if that helps.
  • Any more findings on this? The symptoms describe what I'm seeing to a "T". I am not near my quota, and sometimes the freeze happens at startup, sometimes when searching, and yes it can go for as long as 16 seconds or even more. I thought it might be my computer, but I have three devices (windows 7, windows 8 laptop, and a Surface Pro 3), and the behavior is the same on all three.

  • Here is a debug# 1423628609

    I caused this by just switching to Zotero, searching for one name, then searching for another. Took a long time to respond. There's nothing else other than Chrome running at the moment.

  • try minimizing the tag selector on the left, see if that helps (especially if your computers have a touchscreen or you're using similar technology).
  • At first look that seems to work! Ill play around some and post again of it acts up again. Thanks!
Sign In or Register to comment.