When editing a note, once every minute or two Zotero reverts to a previous version

Lately when editing notes on Zotero standalone, I find that once every minute or two, Zotero discards the last 10 or so seconds of my modifications, reverting to a saved version, and places the cursor at the top of the note. So in the middle of writing a sentence I'll find that the first part of the sentence is gone and the last few characters (until I realize the problem) appear at the beginning of the note.

This happens very consistently and makes editing Notes within Zotero practically impossible. I thought it was a problem with syncing, but I turned syncing off and it still happens all the same.
  • This happens with auto-sync off?

    Can you provide a Debug ID for this?
  • edited May 24, 2013
    Yes, it's very consistent even when auto-syncing is turned off. I'll provide debug output.
  • Debug ID: D2092374658
  • I just tried typing a note again and, like clockwork, about a minute into typing, it undid the last few words I wrote and sent the cursor to the beginning of the note. I submitted the debug output immediately after that.
  • For some reason it now seems to be happening only when auto sync is on. Yesterday it didn't seem to matter if I turned it on or off. I'll keep you updated if the problem comes back with auto sync off.
  • How about if you enable auto-sync but turn off file syncing?

    From your error report it looks like you've been hitting a file sync quota error on each sync. It's possible that that's triggering this. I'll see if I can reproduce that, though I won't be able to look at it for a week or so.
  • That may be the problem. When I turn on autosync but turn off syncing for files in group storage, the problem seems to go away. It comes back if I have both autosync and file sync for group libraries turned on. (I don't have sync for my personal library file sync on because it's too big.)
  • (obviously this is a bug & shouldn't happen, but since you're hitting your storage limit anyway you might as well turn off file syncing.
  • (I think I've offered that advice before, but I realized that file syncing can still be useful if you're in group libraries owned by others, particularly in 4.0, which should continue to sync other group files separately.)
  • Thanks for the suggestions. Actually I've upgraded my storage, since I'm currently working on a collaborative project, so this isn't happening any more. (At least not until I add another 2GB of shared files.)
Sign In or Register to comment.